"null" value

amwdmw
amwdmw Community Member Posts: 97
I am building a course that will be published online....therefore, it must meet WCAG 2.0 AA standards.  I am being told that I need to apply a "null" attribute to some values in the course.  I see that there is that capability to apply an empty alt tag (by checking the box)...or to apply the title of the item as the alt attribute.  I cannot, however, figure out how to give an item the "null" attribute.  Help!

Comments

  • jvalley4735
    jvalley4735 Community Member Posts: 1,357
    Do you need to put in a null alt tag?
    1. Do one of the following to display the Properties ribbon:
      • In the Title Explorer, double-click the graphic of the object.
      • In the Title Explorer, right-click the graphic and select Properties.
      • In the work area, double-click the object.
      • In the work area, right-click the object and select Properties.
    2. Specify the new name of the object in the Name field. For images and buttons, this is also the name that will be used as the ALT tag when you publish to the Web.
  • amwdmw
    amwdmw Community Member Posts: 97
    Yes, that's what I am attempting!  I put double quotes, but it displays the double quotes (wasn't sure if this was a literal translation....seems like it is).  I can't leave the name field empty, but I CAN (most of the time) just use a single space.  I think that might work.  Still testing, however.

    Thanks!
  • timk
    timk Community Member Posts: 1,219 ♦ Idol ♦
    The name of the element in the title explorer is added as the alt text. When you read not-Lectora-related html help pages, they'll say the alt tag must be empty or null, i.e. "". But this is the way it's supposed to look in the published html page, not in Lectora. The only way to achieve that in Lectora is (I believe) by checking "Empty Alt tag".

    If you add "" as the name, Lectora will insert this as the Alt text.

    If you add a blank the Alt tag won't be empty, it'll be " " instead of "". Although I wasn't able to name a button with a single blank only.

    I've attached a screenshot of a page with three buttons. For the "Click here"-button I've checked "Empty Alt tag". For the Next and Previous buttons I haven't.

    You can see in the Firebug window (orange arrow) that the Alt text and the title attribute are empty = ""

    The two lines below that, are the other two buttons with their respective name from the title explorer in the alt and title attribute.

    Tim
  • klaatu
    klaatu Community Member Posts: 988
    Tim, I believe adding null as the title explorer name will also result in a null alt tag.
  • timk
    timk Community Member Posts: 1,219 ♦ Idol ♦
    I my test it resulted in a "null" alt tag, not a null alt tag ;-)