Lectora 12.1.4 Service Update Release Notes

support Community Member Posts: 96
You can see previous release notes and download Lectora Service Packs here: http://trivantis.com/service-pack-downloads/.

A list of the current Known Issues is available here: http://trivantis.com/known-issues.

October 20, 2015

Microsoft Windows

System requirements for this service update:
Lectora Inspire 12.1.3 or
Lectora Publisher 12.1.3

Note: A full install of v12.1.4 may be used by those currently on v12.1.1 or lower.

Installation instructions:

  1. Download the appropriate file (Inspire_Update_v12.1.4.exe or Publisher_Update_v12.1.4.exe).
  2. Double-click the .exe file.
  3. Follow the on-screen instructions.

This service update is available for download in the following languages:

  • English
  • French
  • German
  • Spanish
  • Swedish
  • Chinese
  • Brazilian Portuguese
Lectora Inspire and Lectora Publisher 12.1.4 includes the following updates and fixes:

New Feature

There are no new features in this this service update.

Issues Fixed in this release:

  • LD-1744 - In the previous release a system check was implemented to identify and warn users when the file version of the title being opened is not fully compatible with the version of Lectora being used. Errors were identified and resolved that caused this message to appear inappropriately.
  • LD-1968 - Related to the above, the warning message inappropriately appeared when changing Themes, and canceling the message caused Lectora to crash.
No resolved issues

No resolved issues

No resolved issues

No resolved issues


  • ssneg
    ssneg Community Member Posts: 1,466 ☆ Roadie ☆
    Yay, the bug with wrong background when editing textboxes has been nailed!

  • rfuest6134
    rfuest6134 Community Member Posts: 43
    Thanks for fixing "LD-1061 – Variables are not synched between page and web window page". Now I can delete my workaround with an extra action.
  • support
    support Community Member Posts: 96
    Thanks for the feedback! They really tried to squeeze a lot of fixes into this one, I'm glad it helped.
  • eprenticecentrax-com
    eprenticecentrax-com Community Member Posts: 12
    I have an issue .  I was on version 12.1 and everything worked fine except for the Video Editor would crash when trying to load and MP4 so that I can add Events to it.  So I patched up to version 12.1.3 and now I cannot even open the AWT file.  Any program that I saved with version 12.1 I cannot open it now using 12.1.3,  It crashes every-time.  Please help as I have a deadline before the weekend.
  • eprenticecentrax-com
    eprenticecentrax-com Community Member Posts: 12
    I think I found the issue.  There was an MP4 file with an event assigned to it that worked fine with 12.1.  When I updated to 12.1.3 the AWT file would not load until I went to the Media directory and deleted that MP4 file. Other MP4 files work so far.   Still investigating.   Thanks
  • support
    support Community Member Posts: 96
    You could try re-saving that MP4 file with Camtasia or another video editor. It could be in a different codec that has problems with your computer.