Submit Button Just Stops Working In Test

struitt Community Member Posts: 138 ♪ Opening Act ♪
edited March 31, 2023 in Lectora Desktop

This is an odd one for me so I'll ask everyone.

We have a test with multiple chapters. In those chapters the learner will get a certain amount of questions to answer (i.e. 2 questions out of a possible 5 in the chapter). It is set up where there is a 'Submit' button on each page/question, where it simply processes the question on the page. Nothing fancy. The learner gets 50 questions in this test.

Problem I'm having is when I test it (in our LMS and ScormCloud) it gets to a question and the Submit button just doesn't work. I click and nothing happens. I can select an answer, but clicking Submit does nothing. It has happened early, like after a question or two, and it has worked fine all the way until the 50th question.

I've tried 'this and that' for a total of half a dozen variations, all with the Submit button issue. Does anyone have any suggestions of what else to try before I rebuild the entire course?



  • CarlJFink
    CarlJFink Community Member, Lectora® Accessibility Group (LAUG) Member, eLearning Brothers® Partner Posts: 163 ♦ Idol ♦

    My instinct would be to rebuild just the test, maybe as a separate SCO. I'm a big fan of the programming principle of breaking software (which is what you are creating) into separate units that can be tested and debugged in isolation. Makes debugging far easier.

  • jholland
    jholland Administrator, Rockstar Manager Posts: 114 eLearning ROCKSTAR Admin Team

    @struitt Have you checked each question to make sure each question has the "Enable Feedback" checked on? If you originally used that and added the Submit button, accidentally unchecking this will not remove the Submit button.

    Also, check to see if each Submit button is processing the correct question on the page. Depending on how question pages are created with copying and pasting, some buttons might be out of synch and are processing a question from a different page.

  • jholland
    jholland Administrator, Rockstar Manager Posts: 114 eLearning ROCKSTAR Admin Team

    @struittt When running the course on SCORM Cloud and your LMS, open the Browser's Developer Tools and select the "Console" tab. Look for Red errors in this tab on the page where the button stops working

    Sometimes when a button doesn't work, it is because something else "crashed" the page. A simple syntax error in a custom JavaScript that tried to run earlier could do this and break all the buttons that worked fine earlier.

  • andrew-robertson
    andrew-robertson Community Member Posts: 362 ♦ Idol ♦

    Can you share your product for assistance?

    Andrew R.
    Developing content since 2010 using a mixed bag of tools.