Error message: 'Media error: Format(s) not supported or source(s) not found'.

pdekker7278 Community Member Posts: 6 ☆ Roadie ☆
edited January 17, 2023 in Lectora Desktop


Lately i'm getting errors in my Lectora 21 desktop projects with mp4 video's

Error message: 'Media error: Format(s) not supported or source(s) not found' ,and below this message the path to the mp4 file;

Things I discovered/tested/used so far:

  • the error is generated by the lectora file; mediaelement-and-player.js (line 6966)
  • error occurs with browsers Chrome, Firefox, Edge, Safari
  • the size of the movie doesn't matter
  • the bandwith doesn't matter (tested Wifi, wired and localhost)
  • tested with different servers (localhost/preview in Lectora 21, linux/apache and windows server/iis).
  • tested with SCORM 1.2, 2004 and html output.
  • it doesn't matter if you have 1 or more movies on a page (not sure about this)
  • the lectora html5 video player is based on mediaelement.js. The latest version is 5.1 but Lectora uses 4.2.10
  • mp4-video's are always encoded as H265 MPEG-4 (part10) (avc1) and MPEG AAC audio (mp4a)/stereo/48000 Hz (mostly we use handbrake to optimize video's)

I cannot reproduce the problem (The error seem to occur randomly), so when the error happens i'm to late to watch the network request (and when you refresh the pase the problem is solved).  

I don't know if this is part of the problem but i've discovered some things;

When I open "developers tools" in a browser (F12 on most browsers) and watch "network", I sometimes get and error in the list of (GET) requests. The error doesn't always show up, so I have to refresh the page (F5 and caching disabled) a few times before the error shows up. but it is always the same error. The error shows up with a partial or range request ( Which means something like "give me part of the data from a certain point (in bytes) from a mp4 file until the end of the file or to some other point. The server answers normally with a 206 http status code 206 Partial Content. But in the case of the error there isn't even an answer from the server, it looks like something is already going wrong clientside. In Firefox i'm getting "NS_ERROR_PARSED_DATA_CACHED"...

Anyone having the same errors or a solution?

I've included also the html-output of the Lectora 21 if you're interested

thanks in advance...