Audio: Auto Start

andrew-robertson
andrew-robertson Community Member Posts: 265 ☆ Superstar ☆
edited January 25, 2022 in Lectora Desktop
I know this has been talked about at nauseam, but audio auto-start - does that still function in Chrome and Edge?

I was given the code below a while back and while it works nicely in IE11 (still supporting legacy Flash content until it's demise), it doesn't work in EDGE or Chrome when I test it from the Preview in Browser (Chrome / Edge) option.

Code given to me that i've placed in the bottom of file scripting.


getDisplayWindow().enableAutoStart = function (cb){ cb(); }


Now that I've gone back and re-read the KB documentation ( https://knowledgebase.elearningbrothers.com/tap-/-click-to-continue ), it appears as though i don't have the blank.mp4 video file in my raw development awt file. Do you supposed that would that be the cause of my issue?

Andrew R.
Developing content since 2010 using a mixed bag of tools.

Answers

  • chrystalb21
    chrystalb21 Community Member, Lectora® Accessibility Group (LAUG) Member, eLearning Brothers® Partner Posts: 24 ✶ Headliner ✶
    @andrew-robertson, what version of Lectora are you using? For Lectora 21 I've found that Chrome and Edge didn't show it, but in Firefox the Tap/Click to Continue shows on every page that has audio/video, but if the course is published for Seamless Play, it works. The course I tested was not responsive.

    I did see a difference when publishing the same from a Demo version of Lectora. All browsers worked as expected.
  • andrew-robertson
    andrew-robertson Community Member Posts: 265 ☆ Superstar ☆
    v19 at the moment. I am a little worried as we are working at converting all our content from Flash based to HTML based, and auto-start narration for our content is enabled. So we'll have to go back and edit about 20 modules (40 in total - EN / FR).

    IE11 - Audio auto starts
    Edge - Audio does not auto start
    Chrome - Audio does not auto start

    These are all in preview mode, and not yet fully tested in the LMS (we currently have a system policy in place that when we launch our LMS domain it automatically launches in IE11, no way of circumventing that at the moment).
    Andrew R.
    Developing content since 2010 using a mixed bag of tools.
  • chrystalb21
    chrystalb21 Community Member, Lectora® Accessibility Group (LAUG) Member, eLearning Brothers® Partner Posts: 24 ✶ Headliner ✶
    @andrew-robertson,
    I checked a course with Lectora 19.0.4 (12203)

    Only change made was to add blank.mp4 to our title page - did not add the code you mentioned above.

    Testing Windows 10 Desktop
    IE11 - No tap/click to continue - audio plays automatically
    Chrome - No tap/click to continue - audio plays automatically
    Edge - No tap/click to continue - audio plays automatically
    Firefox - Tap/click to continue on every page.

    Please note, I'm not sure the Firefox issue is for everyone. Based on my testing in Lectora 21. Using the demo version on my home computer, I had no issue, but publishing from our registered version, I do.

    I did not test on mobile.