Setting Debug Options

oglesbay
oglesbay Community Member, Lectora® Accessibility Group (LAUG) Member, eLearning Brothers® Partner Posts: 10 ☆ Roadie ☆
Hello everyone. Veteran user here and am having a hard time with v21 in debug mode. In the past I was able to see all the variables as I was testing. Right now it is only showing the variables on the page I'm currently viewing in debug mode, and when I go to the next page, those old variables go away and only the ones currently on the page show up. I found a help document that says I should be able to change what I see (link) but I cannot find a way to actually do any of this. Can anyone help? I'm loosing my mind trying to solve an issue without being able to see all the variables that I need on one screen! Thanks!
Tagged:

Answers

  • timk
    timk Community Member Posts: 1,235 ✭ Legend ✭
    edited December 6, 2021
    Variables that are not used usually don't exist on a page. If you added a group and put a "Reset all variables" action into it, this should tell Lectora that you need all variables.
  • oglesbay
    oglesbay Community Member, Lectora® Accessibility Group (LAUG) Member, eLearning Brothers® Partner Posts: 10 ☆ Roadie ☆
    That makes sense, but did you see the link I added above? It says we should be able to change what we are seeing when we are debugging and I can't figure out how to do that.
  • timk
    timk Community Member Posts: 1,235 ✭ Legend ✭
    You can modify the "Debug Options" in the publishing dialogue, but as all options are activated by default there won't be much more to show than what you already see.

    In the end the Help is not the best-maintained document there is. For example it still explains the "Double-click" trigger that has been removed with v11.