Republishing a course authored in 19 in 21. HTML version works. SCORM does not

suecamturner
suecamturner Community Member, Lectora® Accessibility Group (LAUG) Member, eLearning Brothers® Partner Posts: 2 ☆ Roadie ☆
Not sure what happened. Published to HTML - and course works as expected. Published to SCORM and uploaded to LMS and fails.

Error message attached

Best Answer

  • timk
    timk Community Member Posts: 1,199 ♦ Idol ♦
    Accepted Answer
    It's a Scorm error. The course tries to save the variable "VarTrivBtnTracking" to cmi.suspend_data. This LMS field has a character limit, depending on the scorm version. The screenshot doesn't show the actual error but looking at the value it is probably too long to be saved.

    I don't know what the variable is meant for but it may be related to the new button state feature introduced with Lectora v21.

Answers

  • suecamturner
    suecamturner Community Member, Lectora® Accessibility Group (LAUG) Member, eLearning Brothers® Partner Posts: 2 ☆ Roadie ☆
    Any thoughts?
  • carlfink
    carlfink Community Member Posts: 961 ✭ Legend ✭
    @suecamturner , you might be able to work around this by publishing to a different SCORM version (say, going from 1.2 to 2004). However, ELB should really be jumping on this to fix it.
  • jholland
    jholland Rockstar Manager Posts: 38 eLearning ROCKSTAR Admin Team
    @carlfink @timk Thanks for your answers. @suecamturner you are experiencing a bug that we just resolved in our last maintenance release. Only some users saw this issue, most likely it is based on the numbers of buttons in the course. Our latest version of Lectora Desktop, version 21.0.3 addresses this issue as one of many issues resolved and improvements made. Please upgrade your Lectora to the latest version, 21.0.3.

    Lectora Desktop updates now use a patch process, so you don't have to download the whole installer as in recent previous releases. To start the update process while within Lectora, click on the help icon in the upper right, scroll down to "Check for updates" and click on this menu choice. Follow the prompts to install the update.