xAPI - Course not setting interactions - just sending "Experienced" - no longer sending "Answered"

joejubee
joejubee Community Member Posts: 323 ✶ Headliner ✶
edited July 13, 2021 in Lectora Desktop
So this is a puzzler... I'm working on a course that mirrors all of the other courses I've worked on, uses the same template that we've used before, but on this bad-boy, no interactions are getting set. Normally for any test that's in the course, it will send something along the lines of:

username incorrectly answered 'PreTest Question 3' with response 'False'

But for this particular course, all I'm getting is:

username experienced 'PreTest Question 3'

Now, none of these require custom xAPI statements - these are the standard interactions that are sent as part of the Lectora test component. I'm sure I could rebuild the course from scratch and it would suddenly work, but it's a really long/complex course, and that would take some time. (I've already tried copying and pasting into a new, blank course, and the same thing happens).

Thoughts?

Answers

  • wheels
    wheels Florida USACommunity Member, Administrator, Moderator, Rockstar Manager Posts: 575 eLearning ROCKSTAR Admin Team
    Hey @joejubee

    I would bring up the browser console and see if there are any red errors. If you are not seeing the statements on any questions then it might by interference from an object or scripting that is inherited to all those pages. Make a copy and remove everything but the test, does it work then? Those are things I would try.
  • joejubee
    joejubee Community Member Posts: 323 ✶ Headliner ✶
    Ok, so I've been able to determine that this is something in Lectora for sure. I've taken a course created last year that is reporting properly, loaded it onto ScormCloud and tested it - it works as expected.
    Then, I republished that same course and tested that version, and that one now doesn't report properly. Waiting to hear from ElearningBros.