Blank TOC - Tree View and Indented List

jasonadal
jasonadal Community Member Posts: 441 ♪ Opening Act ♪
I have a title in v19.0.4 where if I use a Tree View or Indented List Table of Contents, it is completely blank with a white background when I publish as HTML. This is in both Firefox and Chrome. The TOC works as expected if I use Run or Preview within Lectora or preview in browser.

If I change it to a drop-down style, it works and shows all the chapters and pages. I am thoroughly stumped by this, as I've tried a ton of variations on the publish methods (I can NOT used seamless play, so I have not tested that). I've published with or without lightboxes, the title manager, scaling, no scaling, with responsive, without responsive, and I simply cannot get it to work. It happens regardless of whether the TOC is initially hidden or initially visible.

This is a sample that's a little robust, so I've unhid the TOC to start and kept the button that hides/shows it. HELP! :)

Comments

  • cainam
    cainam Community Member Posts: 350 ♦ Idol ♦
    Are you publishing this to a web server, or using it from a local/shared drive? The reason I ask - I tested putting the published html on a web server and it worked fine (but running it from my local drive showed a blank TOC).
    - Adam Cain
  • jasonadal
    jasonadal Community Member Posts: 441 ♪ Opening Act ♪
    cainam said:

    Are you publishing this to a web server, or using it from a local/shared drive? The reason I ask - I tested putting the published html on a web server and it worked fine (but running it from my local drive showed a blank TOC).

    I was only going to the local drive and hadn't yet had the chance to test on a server or an LMS - I had to get it up for primary testing before having a chance to do so. I'd never experienced this publishing locally prior to this version.

    That said, I wonder what would cause the local version to crap out like this. I expect some things will based on varying admin policies, anti-virus, etc., but when it happens across multiples, it feels like a publishing question rather than a local disk question.

    Thanks for testing that out! I might push it to ReviewLink with the actual TOC and see if it's just a fluke with the local publishing.
Sign In or Register to comment.

So You Wanna Be An eLearning ROCKSTAR?

We're all fans of eLearning here! Want to become an eLearning ROCKSTAR? Just click on one of the buttons below to start your rocking journey!