eLBX Online 2021 | June 22 - 24


Join us for a FREE, 3-day virtual conference featuring industry experts and eLearning thought leaders. Learn about critical topics such as eLearning accessibility, learning experience design, course authoring, virtual reality, and gamification. Register today!
CHECK IT OUT

Languages and Screen Readers

vicki
vicki Community Member Posts: 75 ♪ Opening Act ♪
I have a course with the language set as Spanish. A reviewer found that title level buttons (back/next buttons, help, glossary, exit, etc.) are being read in English rather than Spanish. The button names in the title explorer are in Spanish.

The reviewer indicated that the aria-label is in English, not Spanish. How/Where do I fix this?

I am using Lectora 19.0.4. Thanks!

Comments

  • web-foley
    web-foley Community Member Posts: 55 ✶ Headliner ✶
    Hey Vicki,

    I'm curious to where you set your Language. Was it in the "Title Options" window? (Title Setup group) or was it from the Languages Tab in your Publish window.

    I ask because I know that for Select Publish String Set in the Publish window often does not take effect and we constantly have to make sure that both the Lectora Preferences AND the Publish are BOTH set in order to actually deliver our French Publish strings. (I really wish we could just set it on one place)

    -Darrell
  • timk
    timk Community Member Posts: 1,180 ☆ Superstar ☆
    In Lectora 19.0.3. the aria-label of a text button is filled in with the button text. For an image button the name is inserted.

    For all my language versions I only change the publish strings in the preferences and it works. My testing with the "Languages" tab of the publishing dialogue (that I did a while ago) said that it depends on the translation file. If you don't select an RTF the rest of the settings won't do anything. If you selected an RTF the language version should be published with the translated content and the selected publish strings but without changing the AWT. No guarantee here, I've never used it as I've never been able to just publish a translated version that would not require certain language-specific optimization.
  • vicki
    vicki Community Member Posts: 75 ♪ Opening Act ♪
    @web-foley I didn't even think about the language setting in the publish window. I thought that setting it in the Title Options would be sufficient.

    Thanks for the input!
  • vicki
    vicki Community Member Posts: 75 ♪ Opening Act ♪
    edited May 28, 2021
    @timk Based on web-foley's response, I just explored the languages tab in the publish options. The language is set to Spanish, but where do I get/locate an rtf file? Thanks!

    Okay...found info online about creating an RTF file. :)
Sign In or Register to comment.

So You Wanna Be An eLearning ROCKSTAR?

We're all fans of eLearning here! Want to become an eLearning ROCKSTAR? Just click on one of the buttons below to start your rocking journey!