Review Link not getting refreshed.

adilkamal1007
adilkamal1007 Community Member, Lectora® Accessibility Group (LAUG) Member, eLearning Brothers® Partner Posts: 1 ☆ Roadie ☆
Hi all, I am creating quiz in Lectora online version , but when I am publishing it through Review link and playing the quiz the values does not get refreshed or is retained between the sessions as I click on Retry Quiz in the end. Also I have deselected “Retain the Value between sessions” option while creating the questions. It only gets refreshed when I click on “End Quiz” button

.

Answers

  • cainam
    cainam Community Member Posts: 268 ☆ Superstar ☆
    This is the difference between a course that is temporarily hosted in a browser (Reviewlink), and a course that is hosted in an LMS. When hosted in an LMS, the LMS retains the variable data, ties it to each user, and the user can return using any computer/browser and the data remains - so the options such as 'retain value between sessions' is applying to when you publish in SCORM and host in an LMS. When hosting outside an LMS, then the browser is in control of the variable data, and that isn't controlled by those settings in Lectora. For example, if you were to open the same course in a different browser (or I'm guessing an incognito window in the same browser you already opened the course in), then those values would not be saved. (It isn't reviewlink saving the data, but your browser). (This is my understanding anyway - someone can correct me if I'm wrong.)

    What I do sometimes is when I need the values reset, is put either a hidden button somewhere with action to 'reset all variables', or sometimes add that action to my logo in the course. Then I add a note to the title somewhere to make sure I remove the button/action before publishing finally to the LMS. (Adding a 'note' will bold the page the note is on to make it easy for me to identify I need to do something to that page later on.)
    - Adam Cain
  • adilkamal1007
    adilkamal1007 Community Member, Lectora® Accessibility Group (LAUG) Member, eLearning Brothers® Partner Posts: 1 ☆ Roadie ☆
    Thanks Adam for your reply, but if the browser is retaining the value then it should change if I refresh the browser. Here the value is not getting refreshed even after refreshing the browser.
  • cainam
    cainam Community Member Posts: 268 ☆ Superstar ☆
    Not necessarily on the browser refresh. Use a different browser or an incognito window and see if you get the same results.
    - Adam Cain
  • carlfink
    carlfink Community Member Posts: 825 ☆ Superstar ☆
    cainam said:

    This is the difference between a course that is temporarily hosted in a browser (Reviewlink), and a course that is hosted in an LMS.

    Reviewlink is not browser hosting, though. It's a limited/specialized cloud LMS.

    @adilkamal1007, even so Adam's suggestion is a good one--just have an action in your course to reset the values.
  • adilkamal1007
    adilkamal1007 Community Member, Lectora® Accessibility Group (LAUG) Member, eLearning Brothers® Partner Posts: 1 ☆ Roadie ☆
    @Cainam thanks for your response, I tried different browser but got the same result.
  • cainam
    cainam Community Member Posts: 268 ☆ Superstar ☆
    How about the Test BEHAVIOR tab settings? (Is 'Retain Answers Between Sessions' checked there?)
    - Adam Cain
  • adilkamal1007
    adilkamal1007 Community Member, Lectora® Accessibility Group (LAUG) Member, eLearning Brothers® Partner Posts: 1 ☆ Roadie ☆
    Hi Adam, in Test Behavior tab (Retain Answers Between Sessions) is not checked. Also while playing Quiz in Lectora when I click on Retry Quiz button the values are getting retained and not getting refreshed also Timer is not getting refreshed.(Earlier it was happening in Reviewlink and now in Lectora itself.) Please suggest
  • cainam
    cainam Community Member Posts: 268 ☆ Superstar ☆
    Can you test it in your LMS to see if it is behaving as you expect?
    - Adam Cain
  • adilkamal1007
    adilkamal1007 Community Member, Lectora® Accessibility Group (LAUG) Member, eLearning Brothers® Partner Posts: 1 ☆ Roadie ☆
    No Adam it is not behaving as intended in LMS as well.

    -Adil
  • adilkamal1007
    adilkamal1007 Community Member, Lectora® Accessibility Group (LAUG) Member, eLearning Brothers® Partner Posts: 1 ☆ Roadie ☆
    No Adam it is not behaving as intended in LMS as well.

    -Adil
  • timk
    timk Community Member Posts: 1,168 ☆ Superstar ☆
    Have you tried clearing the browser cache? This would be the place where variables and / or form entries are saved. It wouldn't help to refresh the window because the purpose of caching is to make reloading a page faster. Data is saved at least until the browser is closed completely, but it depends on your settings.

    If you checked "Retain between sessions" the data would also be saved in a cookie.

    The easiest way to solve it should be actions to either "Reset test / survey" for the whole test or "Reset question" on the individual pages.
Sign In or Register to comment.

So You Wanna Be An eLearning ROCKSTAR?

We're all fans of eLearning here! Want to become an eLearning ROCKSTAR? Just click on one of the buttons below to start your rocking journey!