Preview in Browser (Chrome) Not Working?

tecocat
tecocat Community Member Posts: 389 ♪ Opening Act ♪
edited February 26, 2021 in Lectora Desktop
I'm trying to preview a page that automatically plays a narration audio file, which has events to show bulleted text timed to the narration. However, when I choose to preview it in Chrome (the only browser my company currently allows), it loads the page, but does not play it (i.e., no audio and none of the bullets coming in). I've already tested the page in Run mode (it works fine), but I need to preview it in the browser to see how the text is laying out (because I know there's often a difference between how it looks in native Lectora vs. on a browser.

Does anyone know why this isn't working and how I can get it to work? I'm using Lectora Inspire 18 (v. 18.2.2), desktop.

Thanks!

UPDATE: The audio plays fine when I preview the title slide, which is just a static slide. The problem above only applies to the next two slides, both of which have the audio with the timed events on it.

Comments

  • cainam
    cainam Community Member Posts: 361 ♦ Idol ♦
    Maybe try publishing in HTML and test from there just to confirm the same thing happens when you get to that page?
    - Adam Cain
  • carlfink
    carlfink Community Member Posts: 947 ♦ Idol ♦
    Current version of Chrome?
  • tecocat
    tecocat Community Member Posts: 389 ♪ Opening Act ♪
    carlfink said:

    Current version of Chrome?

    Yup, it was/is a current version of Chrome!

    The answer to this problem was that I needed to set "localhost" as a "site" that's allowed to play audio in Chrome's settings. Thanks to Sheryl Coggins at eLB for helping me to figure this out!
  • tecocat
    tecocat Community Member Posts: 389 ♪ Opening Act ♪
    cainam said:

    Maybe try publishing in HTML and test from there just to confirm the same thing happens when you get to that page?

    Yes, same problem when published locally to HTML, but not when published to, say, ReviewLink. The answer to this problem was that I needed to set "localhost" as a "site" that's allowed to play audio in Chrome's settings. Thanks to Sheryl Coggins at eLB for helping me to figure this out!