Tap / click here to continue

andrew-robertson
andrew-robertson Community Member Posts: 79 ♪ Opening Act ♪
Hello - I am now getting this message every time I have an autoplay requirement on my slide in the Debug and Preview options, and once I click the message, it loads.

Is there a way to disable this message from appearing? It didn't appear in the Lectora 19.0.1 version of the software. Will this happen when I load it into my LMS?


Comments

  • RichVass
    RichVass Administrator, Rockstar Manager Posts: 24 eLearning ROCKSTAR Admin Team
    Thank you for reporting this issue. We understand your concerns on the behavior of Tap/Continue with desktop browsers for titles built in Lectora version 19.0.4. We have determined that this is an issue with the software and have submitted this to our product team for their consideration with tracking ID LD-7629, however please know that there is no estimation of when this will be addressed.

    To work around this issue, we recommend that you publish with Seamless Play (Publish process, HTML Options tab), which will not prompt desktop browsers, and will only prompt mobile users the first time, as expected. The other work around, especially if using the Web Accessible Title Option, is to not use autoplay on videos. According to many experts, while auto play videos are an annoyance for people without disabilities, for people with disabilities, autoplay can make a site unusable. Please see the following article that explains some of the issues autoplay can cause for people with some disabilities.
    https://www.boia.org/blog/why-autoplay-is-an-accessibility-no-no

    We apologize for this inconvenience, but we assure you that our team is working to provide a solution as soon as possible.
    RICHARD VASS, CPTD |  VP, Customer Success
    Office: 801.854.5179 
    Meet with me
  • RichVass
    RichVass Administrator, Rockstar Manager Posts: 24 eLearning ROCKSTAR Admin Team
    Hey, Andrew - this just in from our Product Dev team:

    For run mode it should not do this, we will address that. For Preview in Browser and in your LMS it will display the Tap / Click page if the Browser does not allow auto-play. Most desktop browsers switched to not allow auto-play for audio (or video audio tracks) until the user interacts with the webpage.
    Lectora-published content checks to see if it's able to auto-play media, if not then it presents the Tap / Click here page (if there is media on the page set to auto-play).

    For desktop browsers you really should only see this once. Please let us know if you are seeing it for every page in your published content. In the meantime, we'll see what's going on for run mode that would be frustrating. Thank you for reporting this issue.

    How to disable it: (last entry)
    https://rockstars.elearningbrothers.com/discussion/424341/how-to-skip-the-tap-click-here-splash-screen
    RICHARD VASS, CPTD |  VP, Customer Success
    Office: 801.854.5179 
    Meet with me
  • carlfink
    carlfink Community Member Posts: 817 ☆ Superstar ☆
    Data point: I turn off all video and audio autoplay in all my browsers.

    I hate it. It uses bandwidth, largely for stuff I don't want. I'd much rather click once to view video than have every commercial site stick those annoying video popups at the bottom of my screen, or autoplay a video version of a news story when I just want to read the text.
  • andrew-robertson
    andrew-robertson Community Member Posts: 79 ♪ Opening Act ♪
    edited February 25, 2021
    Thank you for your responses, feedback, and suggestions.

    While my junior developer raised the issue to me, I was able to upload to my test LMS and launch it in our three browsers (IE11, Edge Chromium, and Chrome) without issues.

    I am now wondering if I should add the code that @RichVass suggested to plan for the future (ie. if our IT dept decides to disable autoplay OR if we start providing content outside of our controlled IT environment). I am not a web-dev pro by any sorts, but what does this code essentially do? Does it simply "auto-click" the Tap / Click here to continue message?
    <script>
    getDisplayWindow().enableAutoStart = function (cb){ cb(); }
    </script>
    

    The nice thing is that we are in a corporate environment, and our user workstations are heavily locked down. And the even nicer thing is that these workstations where 90% of our content is consumed from are locked down to a point where you cannot even browse the web. So I will dig some more and see what we can do internally and maybe do something with the autoplay feature(s).

    edit: more details
  • RichVass
    RichVass Administrator, Rockstar Manager Posts: 24 eLearning ROCKSTAR Admin Team
    Glad to help, Andrew. @wheels , will you take a look at Andrew's comment about the getDisplayWindow code (above). Is he thinking about this right?
    RICHARD VASS, CPTD |  VP, Customer Success
    Office: 801.854.5179 
    Meet with me
  • wheels
    wheels Community Member, Administrator, Moderator, Rockstar Manager Posts: 504 eLearning ROCKSTAR Admin Team
    @andrew-robertson that code snippet will skip the Tap/Click page cover that prompts the user to click and allow for auto-play to work. The Tap/Click page should only display in situations where auto-play is not allowed by the browser (we test for it).
  • andrew-robertson
    andrew-robertson Community Member Posts: 79 ♪ Opening Act ♪
    Thanks @wheels for your response. So I guess we are simply suppressing the message and that audio/video will continue to play if we have it set to auto-play?

    Are there any limitations/exceptions that we should be aware of?
  • wheels
    wheels Community Member, Administrator, Moderator, Rockstar Manager Posts: 504 eLearning ROCKSTAR Admin Team
    The message is being presented because it requires user interaction to enable auto-play. If you suppress the tap/click the content will not auto-play.
  • mspencer-2813
    mspencer-2813 Community Member Posts: 10 ☆ Roadie ☆
    edited February 25, 2021
    RichVass said:



    For desktop browsers you really should only see this once. Please let us know if you are seeing it for every page in your published content.

    I just tested a course on SCORM Cloud and it's prompted this for every single page. I added the workaround code and it appears to have fixed the issue. I'm fortunate it did, because I specifically designed my course to not autoplay *only* for screenreader users. It would be a real shame to have a future update that forcibly overrides a custom solution.

  • wheels
    wheels Community Member, Administrator, Moderator, Rockstar Manager Posts: 504 eLearning ROCKSTAR Admin Team
    edited February 26, 2021
    Please email [email protected] and if you can provide a link to the content and tell them what browser you are using it would help us a lot. It should not be presenting the tap/click page every page on a desktop browser. The only case that behavior is expected is on a mobile device where it was not published with the seamless play option. Thanks, sorry for the inconvenience, but our support team will get this straightened out.

    I will re-check the logic we are using and in the meantime you can disable the tap/click if it provides a better experience.

    How to disable it: (last entry)
    https://rockstars.elearningbrothers.com/discussion/424341/how-to-skip-the-tap-click-here-splash-screen
Sign In or Register to comment.

So You Wanna Be An eLearning ROCKSTAR?

We're all fans of eLearning here! Want to become an eLearning ROCKSTAR? Just click on one of the buttons below to start your rocking journey!