Help! - You must run this content from server error

ahwalek
ahwalek Community Member Posts: 38 ♪ Opening Act ♪
Hello,
I'm in the process of updating some SCORM courses to remove Flash items. They were developed probably 5 years ago. I've made the changes in Lectora 18. After publishing in both SCORM 1.2 and 2004 I get a 'You must run this content from a web-based server Not Found' error. I've tried two LMS', same error.

Another thing to note is I get that error every page of a test, and the test score won't calculate.

Anyone see this error before? I've searched and found someone else asked previously but there weren't any responses.

Unfortunately my Lectora maintenance ended 12/15/2020 so they and eLearning Bros won't help. :Rolleyes"

Thanks,
Tony

Comments

  • cainam
    cainam Community Member Posts: 361 ♦ Idol ♦
    Can you show screenshots of your publishing settings? I remember this type of issue is some version prior to 18 when there were publishing options for 'same server as LMS' or similar. I'd probably start with resolving the error you are getting on each question - does that happen only when published, or do you get any errors when running it from Lectora?

    Have you tried opening up a new course in 18, then copy/paste the content from the old version to the new, just to see if there is some hang-up from something leftover in the older-version publishing settings/content?

    If someone doesn't have a solution off the top of their head, it would help if you could zip up a version of the module and add here (maybe take out most of the content and leave the test?). Someone here might be able to troubleshoot.
    - Adam Cain
  • ahwalek
    ahwalek Community Member Posts: 38 ♪ Opening Act ♪
    edited January 8, 2021
    Thanks for your response cainam.
    When running it as a published HTML, it doesn't throw errors, but it also doesn't track the test, and I'm thinking it wouldn't be able to.
    When trying to Preview in Lectora using the green button, I get an error, attached.

    I haven't tried copy and pasting the content yet, I'll give that a try.

    The first two publish settings tabs are attached. The other three tabs have everything unchecked or no settings.

    Thanks again,
    Tony






  • cainam
    cainam Community Member Posts: 361 ♦ Idol ♦
    Publishing settings all look fine - if I were troubleshooting, just to make sure there is nothing associated with these settings, I would test without Seamless Play and without Protect content, just to see if that makes any difference.
    - Adam Cain
  • ahwalek
    ahwalek Community Member Posts: 38 ♪ Opening Act ♪
    We're getting there.

    I'm no longer getting the error on each of the pages, however the Test is still not processing. It was setup to Process Test when the page after the test appears but it stays on that page. I also tried adding an action to the submit button on the last page of the test, and it also didn't process. I checked all actions related to the test and they seem like they should all still work.

    -Tony
  • cainam
    cainam Community Member Posts: 361 ♦ Idol ♦
    Are you processing the test within the Test Chapter or somewhere outside of it? Beyond that, I'd probably need to view to troubleshoot - if you have the ability to zip it up (you don't have to include all the other content if there is any concern for proprietary information).
    - Adam Cain
  • ahwalek
    ahwalek Community Member Posts: 38 ♪ Opening Act ♪
    Thanks Adam. I'm hesitant to provide the Zip for the reason you mentioned. I have the processing of the test within the Test folder structure. That said, I tried deleting the entire test and placed one question in it. I got the same issue of the Test not processing.

    Perhaps its an issue with my installation as the Green Button preview always throws an error. When adding a new test from scratch all of the buttons that come trigger the following error: 'Error Copying resource file - The system cannot find the specified path'. Maybe during the zip compilation it's not able to copy a required file to have it operate correctly.
  • cainam
    cainam Community Member Posts: 361 ♦ Idol ♦
    How about this - can you test out this simple test I have attached here and see if you have the same issue?
    - Adam Cain
  • jholland
    jholland Rockstar Manager Posts: 35 eLearning ROCKSTAR Admin Team
    A suggestion on a side issue. If you are updating these courses to remove flash content, you should choose the "HTML 5 Only (No Flash included)" option on the "HTML Options" tab when Publishing. This will eliminate the flash browser helper included for old browsers.
  • ahwalek
    ahwalek Community Member Posts: 38 ♪ Opening Act ♪
    Thanks Adam. And jholland for the suggestion.

    I think it was an issue with my installation. Our C Drives are locked down such that you can't write to them. I ended up getting version 19 installed to my D drive. Once I published and tested the SCORM 1.2 course in the LMS, it throws no errors and the test calculates and communicate completion and score to the LMS as expected.

    Thanks for hanging in there with me!

    -Tony H