Audio/Video Sync issue in SCORM 1.2 packages

carlfink
carlfink Community Member Posts: 1,099 ✭ Legend ✭
I published a CVR scenario as SCORM 1.2 and imported it into our LMS. The audio and video got wayyyyy out of sync. In a 5 minute video, they ended up 1 minute(!) out of sync. I checked, and this does not happen if I publish to CVR itself and play using the app, and also does not happen if I publish directly to ReviewLink. If I import the SCORM zip file into RL, the sync is absurd. You can hear the speaker's voice going normal speed, while his gestures are in slow motion. Seems like a bug. Playing the SCORM package in Google Chrome current. Thanks.

Comments

  • t_johnb
    t_johnb [email protected] Community Member Posts: 294 ☆ Roadie ☆
    I think you're referring to audio within the video itself, which is not a function of published content, its a function of a server being optimized to stream out video at an appropriate rate, so that the audio and video streams do not buffer. Many LMS's are not optimized for video, especially 4K video. The CenarioVR server is optimized for content delivery, which is why it works well when hosted on CenarioVR.
  • carlfink
    carlfink Community Member Posts: 1,099 ✭ Legend ✭
    Hi, John. I've actually been involved in server hosting and video production myself. Sync shouldn't get that far out of wack because of anything the server does, but I suppose it isn't actually impossible. I note that ReviewLink is your own product, so I assume you can confirm that it isn't optimized for high-end video.

    However, that wouldn't explain why the exact same CVR scenario, uploaded directly to RL (which I have been assuming uses SCORM 2.4, but that's a pure guess) doesn't experience the same sync issue.
  • t_johnb
    t_johnb [email protected] Community Member Posts: 294 ☆ Roadie ☆
    Content being streamed from a server does not have control over how the server performs. As you say, the content works well when running on CenarioVR servers, which are optimized for video delivery.
  • carlfink
    carlfink Community Member Posts: 1,099 ✭ Legend ✭
    My question, though, is why performance is (in my admittedly very limited testing) is different on the same server (yours) when publishing as SCORM 1.2 or directly to ReviewLink (which, as I say, I have been assuming is really a transparent publish to SCORM 2.4 followed by automatic upload).

    I'll be fine if you just say, "That is probably a coincidence," by the way. It likely is.
  • t_johnb
    t_johnb [email protected] Community Member Posts: 294 ☆ Roadie ☆
    By direct publish to ReviewLink, are you referring to publishing from Lectora? CVR doesn't have a ReviewLink publish which threw me a bit off there.

    Lectora actually just uses an HTML publish for its native ReviewLink publish, no SCORM 2004 involved. A SCORM1.2 publish (or 2004) is just a wrapper in how the course sends results to the LMS, so again, won't affect how it sends video to the browser.

    So, I have to say it.... sounds like a coincidence....