Pan from an event ... does nothing at all?

carlfink
carlfink Community Member Posts: 1,099 ✭ Legend ✭
I have an event 32 seconds into my scene that is supposed to pan to a question, while pausing the video. The idea is that the viewer must answer the question to proceed.

The multiple actions are to show the question (initially invisible), and to pan to it. However, the pan never happens. The viewport continues to sit wherever I happen to be looking when the video pauses.

I also have an action at 0:00 to pause the video and display an information card which tells the viewer what to do. However, about 1/3 second of audio and video plays before the pause (which again, is at 0:00). And there's a pan action in that event as well, which works in terms of moving the viewport to point at the information card ... unless you put the info card above the initial (horizontal) "eye plane," in which case the camera moves right or left, but never up or down. This is, in my opinion, not desirable.

All the above is based on the development environment and preview. The behavior is identical in the iOS app. (Does pan even work there, with its accelerometer-based viewport?) When I take it using the PC web client (in Google Chrome), there is a shorter "blip" of sound before the 0:00 event manages to pause playback. In the Oculus Go headset, the pre-pause sound is so short it seems like a click, even though it's actually part of a vehicle-backing beep.

I hereby give you authority to view scenarios in my account. This is the Cut and Clear scenario. Trial account around my email, which I know John Blackmon has because he emailed me last week ....

Comments

  • t_johnb
    t_johnb [email protected] Community Member Posts: 294 ☆ Roadie ☆
    Hey Carl,

    The Question object is a complex object that creates several things under the covers, a background, text, and hotspots for each choice. If you have the two actions immediately next to each other, its likely that it is not quite done being shown when you issue the "Pan To" action, so the object is not there to pan to yet. Try putting an action in a tenth of a second after that Show action to Pan to it. You would then have an action at 32 seconds to show it, and an action at 32.1 seconds to pan to it.

    On the video scene, yes, if you are trying to pause it immediately on run, we recommend you don't have sound at the 0:00 frame as the system may play that as its loading. Your best bet would be to make sure that the first second does not have that noise in it.

     
  • carlfink
    carlfink Community Member Posts: 1,099 ✭ Legend ✭
    In my tests, CVR won't pan to a non-visible object, and will never pan to a question. It has no problem panning to an infobox, if the infobox is visible.
  • carlfink
    carlfink Community Member Posts: 1,099 ✭ Legend ✭
    Correction: I was able to make it work. I think I had the events in the wrong order.