Problem with Entry field in a quiz

mlapl1
mlapl1 Community Member Posts: 349
Hello

I have a quiz that contains several entry fields. I compile the Lectora file into a SCORM file. I upload this to a more or less up to date version of moodle.

The problem is that, apparently randomly (but I don't think it really is), the entry field refuses to accept input. The cursor retains its arrow shape and it is impossible to enter the field. It IS possible to reproduce the behavior inside Lectora but it is impossible to predict which fields will be affected. In one run of the title, ALL the fields were disabled, whereas in another run of the same title, only one field was disabled. I am using a version of Lectora 17.

Thanks for any help.

 

Comments

  • cainam
    cainam Community Member Posts: 290 ☆ Superstar ☆
    Have you tried to determine if this is a Moodle-specific issue, browser-specific, or do you experience the same results in any browser/hosting location?
    - Adam Cain
  • wheels
    wheels Community Member, Administrator, Moderator, Rockstar Manager Posts: 530 eLearning ROCKSTAR Admin Team
    If they are part of questions do you have number of attempts enabled, possibly attempts are not persisting correctly... if you have an example environment this happens in please submit to [email protected] and give them access, reference this forum post.
  • carlfink
    carlfink Community Member Posts: 842 ☆ Superstar ☆
    Adam and Joe: Andrew says the problem sometimes occurs in the Lectora development environment, so it can't be a Moodle thing.

    Andrew: please post your exact Lectora version. Does it happen only on this one course?
  • wheels
    wheels Community Member, Administrator, Moderator, Rockstar Manager Posts: 530 eLearning ROCKSTAR Admin Team
    Hi Andrew (@mlapl1),

    I've checked with support and looked through previous issues. There was one issue in v12 where this would happen if you published with the protect content option checked. That was fixed previous to v17. Maybe it has to do with your title as Carl suggests?

    If you have an minimal example title where you see the problem please post it here.

    I assume you are seeing this in Chrome, as Lectora run mode is Chrome based. Let us know if you have tried it in multiple browsers.

    Thanks for reporting this, look forward to helping solve this!

    - Joe
  • mlapl1
    mlapl1 Community Member Posts: 349
    Hello everyone and thank you for all the ideas. The problem did in fact appear in Lectora. I think I have solved it (not quite sure yet) and apologize to you for all of your attention to this issue.

    The original layout created by the question editor was modified by one of the people working on this title. In making the changes they accidentally made the question field partially overlap with the entry field. When I noticed this, I went through all the questions, making sure that no overlap happened. The problem *appears* to have gone away. I say "appears" because the error seemed to appear randomly whereas you would expect the error I described to be systematic. Perhaps it depends on the point at which one clicks in the entry field...

    Anyway, I really do want to apologize to you all who have been trying to figure out the error. I will write again if the error returns but, until then, we can probably let the matter rest.

    Thank you so much

    Andrew

     
Sign In or Register to comment.

So You Wanna Be An eLearning ROCKSTAR?

We're all fans of eLearning here! Want to become an eLearning ROCKSTAR? Just click on one of the buttons below to start your rocking journey!