Issue with buttons in 18.1.0

broeme Community Member Posts: 93 ♪ Opening Act ♪
Good afternoon everyone.  I've got a strange issue involving buttons and I'm wondering if anyone else is experiencing a similar symptom.

I updated to v18.1.0 yesterday morning, but just noticed today that after publishing a course, some buttons aren't working properly.  After researching which buttons were affected, I think I've found a pattern.  Any button set to initially hidden when the page loads, seem to be broken.  By broken, I mean that once the button appears on screen, it simply does not function properly.  I mouse over it, but don't get the finger icon.  I click on it, but nothing happens.  Any button that is NOT set to be hidden on page load is working just fine.  I don't think the button's location under a group has any bearing, but I have yet to prove/disprove that theory.

The type of button doesn't seem to matter.  I have transparent buttons as well as image buttons and they both malfunction if they are initially hidden.  They work fine if initial visible.

Some other things I've done is a test publish using my previous Lectora version (v18.0.2).  If I take the same course AWT file (created during v18.1.0 opening) and publish it using 18.0.2, all buttons work just fine and as expected.  Lastly, in my new v18.1.0 course, I've swapped the onload display setting of two buttons.  A button that was previous set to initially hidden was changed to display onload.  After that change, the button worked as expected.

Thanks in advance for any feedback.



  • broeme
    broeme Community Member Posts: 93 ♪ Opening Act ♪
    Quick update.  Looks like I'm experiencing the same issue whether a button is grouped or sitting there by itself.  If it is set to initially hidden on page load, that button will not work for me once it becomes visible.
  • broeme
    broeme Community Member Posts: 93 ♪ Opening Act ♪
    Did some additional testing over the weekend and here are my results.

    It didn't matter which e-learning standard I selected.  SCORM 1.2, 2004, xAPI, and AICC all produce the same result.  If any of those are imported to SCORM Cloud, initially hidden buttons on the page do not function.  If I publish to HTML and run it locally, same result.

    If I use the "Preview in Browser" feature, the buttons DO work as expected.  This semi-publish of a page doesn't seem to be affected like a full publish.

    This issue doesn't appear to be specific to any browser.  I can replicate the button troubles with Edge, Chrome, and Firefox.
  • wheels
    wheels Florida USACommunity Member, Administrator, Moderator, Rockstar Manager Posts: 655 eLearning ROCKSTAR Admin Team
    This issue was confirmed and has been fixed in v18.1.1 which was released yesterday.

    Thank you for reporting this, we make every effort to ensure our releases are rock solid but we always watch for feedback like this after a release to ensure we are releasing a quality product. Your post has helped us and has helped the community and we appreciate it!

    - Joe
  • broeme
    broeme Community Member Posts: 93 ♪ Opening Act ♪
    Thanks Joe!  I appreciate the quick response and fix.  I'll grab the new update.

  • approg
    approg Community Member Posts: 258 ♪ Opening Act ♪
    You what would be better than a quick fix from Trivantis?

    Properly testing the software before they release - so we aren't be used as their beta testers (again)!