I can upload to ReviewLink but not to Scorm

amansfield8753
amansfield8753 Community Member Posts: 18
I am working with a course that I had previously published to SCORM and is active in our LMS.

I was asked to make an edit to the course and remove a page. I removed the page (it was just 1 image, a text box and text. No variables), renumbered my pages, ran the course in Preview mode to check the tracking, and everything appeared normal.

When I tried to upload the course to SCORM I instantly received an error stating Error Copying the background image that I used for my course. I double checked and the background is in the Images Folder where it should be. Underneath it say's "Error Creating file" and then immediately stops.

I was then able to successfully publish the course to ReviewLink without a problem, all of my images where there, and my variables/actions worked.

Does anyone have suggestions on what to try to upload my course to SCORM?

 

Comments

  • cainam
    cainam Community Member Posts: 361 ♦ Idol ♦
    Maybe start with swapping out the background image for another, and see if the problem is with that specific image being used?  (shouldn't be, but at least that might help diagnose).
    - Adam Cain
  • brobertson4402
    brobertson4402 Community Member Posts: 24
    Hummm ... sounds like your SCORM publishing is running into an issue.  Theoretically, the folder containing your published work for ReviewLink can be different than for SCORM so one working doesn't necessarily mean the other is too.

    When you publish to SCORM, check the path to your publish folder in the html tab and delete the contents of that folder using your File or Windows Explorer outside of Lectora before actually publishing with Lectora.  Also make sure you select 'publish all pages' and not just the updated pages on the html tab when publishing.
  • timk
    timk Community Member Posts: 1,205 ♦ Idol ♦
    To me it reads like the issue is caused by the "old" version not the new one. I mean, why would it throw an error if the background image was missing in the new package? The image would just not be overwritten.

    On the local machine an error like this occurs when you try to overwrite a file that's currently open in another application. When exactly does the error happen? - During publication from Lectora or during upload to the system?

     
  • amansfield8753
    amansfield8753 Community Member Posts: 18
    Thanks for the help everyone. Brian, was correct and the issue had to do with the file path.