Open Attachment in Offline Course doesn't work

theav-ator
theav-ator Community Member Posts: 69 ☆ Roadie ☆
Note: I haven't updated to Ver. 18 yet, so still operating on Ver. 17.

I have a course that is published for offline use (exe). I have a few buttons in there that should open an attachment (pdf in all cases). The PDFs are all attached and show up in the resource manager.  When previewing the course and when running the published course, clicking the button does not open the PDF. Running the debug mode shows that the action fires, but the action produces no results. Anyone have any ideas why it might not be working? Is it because it's an offline exe? I know this had worked in previous versions, but for some reason is no longer working as expected.

Comments

  • timk
    timk Community Member Posts: 1,176 ☆ Superstar ☆
    It's working for me with Lectora 17.0.6

    You might try "Go to web adress" -> yourfile.pdf, which also works for me.
  • theav-ator
    theav-ator Community Member Posts: 69 ☆ Roadie ☆
    I'm on 17.1.7, not sure if that makes a difference. I'll try your other suggestion and see if that works. Thanks!
  • klaatu
    klaatu Community Member Posts: 988
    Make sure the computer it is running on associates .pdf files with Adobe Reader also make sure Adobe Reader is up to date. Reader can be finicky.
  • theav-ator
    theav-ator Community Member Posts: 69 ☆ Roadie ☆
    Thanks Darrel,

    Although that makes me wonder... On my system it doesn't open and I have the full Acrobat DC included with Creative Cloud. And the person I have testing it I think is also on at the very least an Acrobat Pro version. Does Lectora limit its functionality to just Adobe Reader, or would either Reader or Acrobat work? Or any PDF viewer for that matter as long as it's set in the computer's defaults? Now, our customers themselves, or really customers' customers, would only have Reader installed so maybe just testing on a more similar system will verify.
  • carlfink
    carlfink Community Member Posts: 841 ☆ Superstar ☆
    Acrobat Pro has worked for me in multiple versions.

    Note that all versions after 17.0.6 are known to be buggy.
Sign In or Register to comment.

So You Wanna Be An eLearning ROCKSTAR?

We're all fans of eLearning here! Want to become an eLearning ROCKSTAR? Just click on one of the buttons below to start your rocking journey!