Empty Browser Window with LMS Preview

dpooler9997 Community Member Posts: 8
Hi All!

I'm in Lectora 18. I'm trying to publish to an LMS. The LMS has a preview available so we can verify our content before making it public. When I attempt to preview my lesson all I get is an empty browser window. I suspect there's something about this lesson that is the issue as it is one of a series and the rest are publishing without a problem. One of my peers mentioned a problem with page names with special characters so those have already been removed. Sadly, that didn't fix my issue. I did delete the files out of the scorm folder before I republished.

I also tried turning on the debug publishing option (all debug options were left checked). This gave me the attached pop-up with I tried to preview in the LMS. Honestly, I'm not sure it has anything to do with my issue but I've attached it just in case.

Thanks in advance for any help you all can provide.


  • wheels
    wheels Community Member, Administrator, Moderator, Rockstar Manager Posts: 528 eLearning ROCKSTAR Admin Team
    Hi Dora,

    When the course window is up click in the address bar, or some part of the browser window and press F12 to bring up the browser debug window. Then is should show the "console" somewhere, see if you see any red errors in that. If so, email that to support and reference this post. You might also try adjusting publish options, can you screenshot the HTML options tab and post it here?

    - Joe
  • dpooler9997
    dpooler9997 Community Member Posts: 8
    Thanks for your response Joe. I pulled up the browser debug window and didn't see any errors in the console area. Here's a screenshot of my HTML options that I'm using.
  • wheels
    wheels Community Member, Administrator, Moderator, Rockstar Manager Posts: 528 eLearning ROCKSTAR Admin Team
    No surprises in your publishing options. I would say contact support if your maintenance is current. It would help if you can provide them your title.

    Here is a method to try and find out where the problem is at:

    1) See if publish to HTML works, or page preview on that page, if you can then you can do that to test when trying the next two steps...
    2) Make a copy of the course and remove items until the publish works to isolate the problem to a specific item
    3) Or create a new title and copy things from the failing title into the new title until you see the failure again
  • dpooler9997
    dpooler9997 Community Member Posts: 8
    So, in the course of troubleshooting it's looking like my images and shapes are becoming transparent. I suspect this is a Lectora 17 to 18 transition issue. I'm going to continue rebuilding and see if my suspicions are correct. The game is afoot!
  • carlfink
    carlfink Community Member Posts: 841 ☆ Superstar ☆
    You might try uploading to SCORM Cloud (http://cloud.scorm.com). It's a free service and what Trivantis often recommends for testing.

    I'm wondering if there might be a problem with the SCORM packaging/importing. I once had a similar problem because the import into the LMS was done wrong (wrong version number).
  • dpooler9997
    dpooler9997 Community Member Posts: 8
    I figured it out! After many hours of troubleshooting I was able to find the problem; a poorly named JavaScript function.

    I had a Greensock JavaScript function named "name". Apparently that can be bad juju even though "name" is not a reserved word. I have since learned that "name" is not recommended to be used to name functions. It is an unofficial reserved word. Once I changed the name of my function, my lesson worked as designed.

    Thanks everyone!

Sign In or Register to comment.

So You Wanna Be An eLearning ROCKSTAR?

We're all fans of eLearning here! Want to become an eLearning ROCKSTAR? Just click on one of the buttons below to start your rocking journey!