Test Advance Issue in html

mzilkowsky6863
mzilkowsky6863 Community Member Posts: 10
I have created a very simple eLearning and inserted a test. When running the course on ReviewLink, the questions progress properly.

When publishing to html, I get an error of "You must answer all of the questions to continue." after I make a selection on question 1 and hit next. I have attached an image of the error. Is there something that needs to be done differently for a test in html? Or do I need to check or uncheck something in the publish steps?

Thanks

Mike

 

Comments

  • carlfink
    carlfink Community Member Posts: 842 ☆ Superstar ☆
    Unimportant: spelling of "extinguisher" is wrong. :-)

    Next on the last page of a test should be Submit instead. If it's a one question test, you need a Submit button there.
  • mzilkowsky6863
    mzilkowsky6863 Community Member Posts: 10
    There are 12 questions. it all works fine in Run and Preview, also viewing through ReviewLink.. but when I html it and try to run it from the index file, it gives the error when clicking next after the first answer.
  • mzilkowsky6863
    mzilkowsky6863 Community Member Posts: 10
    If you mean the spelling in the file name, that is on purpose so that I can have 2 copies on the go ans have one with just a few unsaved changes.

     

    I have a Done button instead of submit on the last Test page. It has actions of process test and goto next page already attached to it.
  • lwilson7839
    lwilson7839 Community Member Posts: 12
    Two questions for you, Mike:
    1. What version of Lectora are you publishing out of?
    2. Do you have any conditions on that next button?
    I tried to recreate this issue with a different test and the "Student Must Answer Each Question" checked in Test Behavior, and I was okay. I was publishing out of Lectora Inspire 18.

    If we can't figure it out here, I'd be happy to start a support case for you and take a closer look.
  • mzilkowsky6863
    mzilkowsky6863 Community Member Posts: 10
    I am running Lectora Inspire 18. The Next button only has the action - OnMClkGoto Next page.

     

    It operates fine in the Reviewlink version and in Run and Preview mode in Lectora.

     

    Once published to html, I launched it from running the Index chrome html document it will not advance past the first questions as I get the error.

     

    I might be doing something wrong as I just started using this software after purchasing the large package. I will go into the Intermediate training today and watch those videos to see if I am missing something that might be covered in there.
  • timk
    timk Community Member Posts: 1,176 ☆ Superstar ☆
    It may be related to Seamless Play. Did you open the content via the "Preview" button in the publishing dialog? If you publish with Seamless Play the course won't work when just opening the index.html from the html folder.
  • mzilkowsky6863
    mzilkowsky6863 Community Member Posts: 10
    I was trying the index file from the folder... Should I take Seamless play off and try?

     

    I have other programs created in other software that I can play by opening the index file

     

    I would like to be able to take this content and put it on a usb stick to be able to deliver it anywhere outside of our LMS.
  • timk
    timk Community Member Posts: 1,176 ☆ Superstar ☆
    You can try both ways of course. Seamless play requires the content to be run from a server. If you want to launch it from a USB device you should turn Seamless Play off unless you can provide a virtual server.
  • mzilkowsky6863
    mzilkowsky6863 Community Member Posts: 10
    Turned Seamless off and still have the same issue.

     

    Published for Offline use and it worked properly. I will try publish to html again and running it through the Preview button on the Publish pop up.
Sign In or Register to comment.

So You Wanna Be An eLearning ROCKSTAR?

We're all fans of eLearning here! Want to become an eLearning ROCKSTAR? Just click on one of the buttons below to start your rocking journey!