Test score is always 100

lpauer7193
lpauer7193 Community Member Posts: 11
I have a title with a test with 10 questions (drag and drop and multiple choice questions). The point values are not the same for every question, the total amount of points are 30. The lowest passing score is set to 70%. The problem is, no matter what my answers are, on the result page the score is 100% and success.

What could be causing this?

Comments

  • sirwise23
    sirwise23 Community Member Posts: 442 ☆ Roadie ☆
    Hello,

    When you say the total amount of points are 30, what exactly do you mean?  The point value is not meant to add up to something they are used to gauge the weight of a question.  So by default all questions are equal at 1 point.   If you make a question worth 2 points then it's worth twice as much but they are not meant to add up to anything.  The text maximum score will always be 100 I believe.
  • lpauer7193
    lpauer7193 Community Member Posts: 11
    Hi,

    I mean some of the questions worth 1 point, others 3, or 5, or whatever.

    I'm fine with the maximum score being 100, the problem is that it is always 100. Even if I answer all the questions wrong, my score is 100 and I passed the test.
  • cainam
    cainam Community Member Posts: 290 ☆ Superstar ☆
    If you are using the 'Show test Results' page, from your Test Results tab, maybe the quickest thing to troubleshoot would be to remove that checkbox (so that the test result page is no longer present), and then recheck that box so that it recreates the logic.  That might work for you.
    - Adam Cain
  • sirwise23
    sirwise23 Community Member Posts: 442 ☆ Roadie ☆
    I find that this fixes most issues I have with the results page.
  • lpauer7193
    lpauer7193 Community Member Posts: 11
    Thank you, but the results page is definitely not the source of the problem here, the test score is generated wrong. First I wanted to display the variable value in a text box - using the VAR(variable_name) format, and here the value was always 100. I only added the results page later.
  • cainam
    cainam Community Member Posts: 290 ☆ Superstar ☆
    ahh, you didn't mention the setup - things to check (or it might be quicker share your title to troubleshoot)

    -so it sounds like you have a generic text box, and then an action when the page/text shows to 'change contents' of the text box to the 'Test_Score' (or whatever name the test is)?

    Does the test get graded before this action fires?
    - Adam Cain
  • timk
    timk Community Member Posts: 1,176 ☆ Superstar ☆
    Which version do you have?

    I tested in 17.0.6: 10 Questions with 8 worth 1 point and 2 questions worth 10 points. When I answer only those 2 correctly, the score is calculated as 20 / 28 = 71% which should be correct.

    Can you post a sample?
  • lpauer7193
    lpauer7193 Community Member Posts: 11
    Hi,

    I wanted to upload my title here, so I removed everything form it but the test itself. I tested it before the upload, and now it 'magically' works as intended, even when I put the rest of the title back.

    So I have no idea what happened, but it seems to be working now.
Sign In or Register to comment.

So You Wanna Be An eLearning ROCKSTAR?

We're all fans of eLearning here! Want to become an eLearning ROCKSTAR? Just click on one of the buttons below to start your rocking journey!