Closed Captioning Not Showing

deb
deb Community Member Posts: 42 ♪ Opening Act ♪
I've published my training program to html. It has been loaded onto our server and we have a link on our website.

I have 2 videos with closed captioning. I used the recommended webvtt for my captions. Now that it is uploaded, the CC does not play automatically, and the CC button is not showing on the controller. It worked in reviewlink. Not sure if the issue is our server, the browsers, or something else. Can anyone help?
«1

Comments

  • astafford3593
    astafford3593 Community Member Posts: 12
    I'm having a similar issue. I have a WebVTT file, a controller, and do not have Auto Start or Rollover selected in my playback options. Everything works perfectly in preview/run mode, but when I publish my course for HTML, it doesn't work. It works fine in Firefox, but that doesn't help me when we use IE. I can't figure it out. There is a preview button in the Publish Title to HTML box and it works fine in IE and Chrome, but the files run through localhost. It's the only thing I can tell that is different. I'm wondering if it has to do with the network. You'll have to keep me posted if you come up with a solution. Sorry, I'm not much help, but I feel your pain. Hang in there!
  • swu7570
    swu7570 Community Member Posts: 12
    Hi Deb,

    I can take a look into this today and see if we can get it fixed for you.  Do you have the name of the course or a pkg file that contains the issue?  Once I run through it I'll be able to let you know if it can be fixed immediately or in our next maintenance release.

    If you can also let me know the org name it's under, that would help.  Thanks!

    -Stephen
  • astafford3593
    astafford3593 Community Member Posts: 12
    Good morning, Stephen,

    Is this a known issue? I'm curious as I'm having a similar issue.

    Thank you,

    Abby
  • deb
    deb Community Member Posts: 42 ♪ Opening Act ♪
    Stephen,

    That would be great. My org is Michigan Department of Education (MDE).

    My program is on Lectora Online and is titled Assessment Selection Guidance.

    Let me know if you need anything else.

    Thanks,

    Deb
  • swu7570
    swu7570 Community Member Posts: 12
    Good morning Abby,

    As far as I'm aware, this is not a known issue.  I tested a quick sample just now in IE11 version 11.285.17134.0, publishing to HTML and the captions appeared to work as expected.  Same expected behavior with run mode and publish preview as you both mentioned.

    I'd like to take a look and debug with the titles that you or Deb are experiencing the problem with. That should help me track down the issue much more quickly.  If you are able to provide me the export pkg or name of your title and if possible the video in question, that would be helpful.  If you prefer to just give me the name of the title and your org, I can look it up through that also.

    Hopefully can get this turned around for you guys quickly and apologies for the inconvenience

    -regards,

    Stephen
  • deb
    deb Community Member Posts: 42 ♪ Opening Act ♪
    Stephen,

    I neglected to mention what/where the videos are. I have two at the very end of the introduction chapter named: MI-Access P Example and MI-Access SI Example.
  • swu7570
    swu7570 Community Member Posts: 12
    Great, thanks Deb

    Will give an update soon as I can
  • swu7570
    swu7570 Community Member Posts: 12
    Hi Deb/Abby,

    Quick question, can you either screenshot or describe what Publish Options you used when you published out these titles that are causing the problem.  Testing your title Deb, I did notice the published out standard HTML onto a server that I only run into the problem described on the Chrome browser. In FF and IE11 the captions continued to show.

    For a quick test, would you ensure that your Published Options that you have all the checkboxes under "Published Content" unchecked (See attached screenshot).  We will be able to provide a code fix to handle this but just wanted to see if doing that, if you see any changes in behavior as I did immediately.

    -regards,

    Stephen
  • deb
    deb Community Member Posts: 42 ♪ Opening Act ♪
    Hi Stephen,

    I did not have all my boxes unchecked. I will make that change, but unfortunately I can't get the program uploaded again until next week (Weds/Thurs). Is there any reason I couldn't keep the scale content to fill window checked, or should I have everything unchecked to test this?
  • swu7570
    swu7570 Community Member Posts: 12
    Hi Deb,

    I'm taking a look into that now.  The "Scale content to fill window" appears to be causing the bug where the CC text is behind the video content from what I see.

    With a code fix, you will be able to keep the scale content to fill window for sure but for now I was wondering if you would have been able to verify if having it unchecked to test.
  • deb
    deb Community Member Posts: 42 ♪ Opening Act ♪
    Stephen,

    I was finally able to check my program uploaded with all boxes unchecked and I can see it in Chrome, but not Firefox or IE.

    Deb
  • swu7570
    swu7570 Community Member Posts: 12
    Hi Deb,

    That is odd, I just tested your title from our servers without anything checked and they ran correctly across all 3 browsers.  Do you have a link possibly to your LMS or servers of the published content and I can take a look?

    Aside from that, we will try and get the fix for the original issue of the CC not showing (regardless of publish options) in one of our near upcoming releases.  Will post the exact date/release # on here when it's available
  • deb
    deb Community Member Posts: 42 ♪ Opening Act ♪
    The current link to the program is:

    https://qa.mdoe.state.mi.us/mdedocuments/AssessmentSelectionGuidelinesTraining/assessment_selection_introduction_p_example.html

    I just checked it again from my laptop out of the office—I checked it on my IMAC (Chrome and Firefox) and a PC (IE) in the office the last time—and this time I couldn't see the CC on Chrome or Firefox. I am on a mac, so I can't check IE.

    Could it be something with our servers?

     
  • swu7570
    swu7570 Community Member Posts: 12
    What version of LO are you publishing with?

    There's a couple issue I'm seeing with that link.  The CC tab in your title isn't showing up originally, until the window is clicked/moved.  Once showing I'm seeing the CC is set to "None" instead of "On", which usually toggles the CC going on and off.  For testing this page, would it be a big issue for you to do a clean caption file on a new video object with the default controller?

    I add a screenshot of what I'm seeing from the link

     
  • deb
    deb Community Member Posts: 42 ♪ Opening Act ♪
    It looks like I'm working in LO 4.2. I checked my preferences and they are set to having CC set to on.

    I don't have the freedom to keep posting files. I have 2 week intervals that they will do this, so it makes it hard to test. What I have done is changed the videos I do have in the program to the default controller. When I publish it and open the home file on my desktop, I do see the CC tab and it is set at "on." I have asked if they will replace my file to test this. I am waiting on a reply.

    I do appreciate your assistance with this!
  • swu7570
    swu7570 Community Member Posts: 12
    Thanks for the clarification Deb, I understand that since you're not the one posting the file, it does make the testing a bit harder.  Let me know what you see when they do change the file.

    In the meantime, are you able to test this link on my side and let me know if you are able to see the captions?

    http://dev.trivantis.com/stephen/assessment_selection_introduction_si_example.html
  • deb
    deb Community Member Posts: 42 ♪ Opening Act ♪
    Stephen,

    Yes, I can see the CC in both Chrome and Firefox when I open your link.
  • clammers
    clammers Community Member Posts: 123 ♪ Opening Act ♪
    Is this solely a Lectora Online issue? I use Inspire and am encountering a similar issue. Captions (WebVTT or SRT) appear in Preview and Preview in Browser mode (and can be toggled on/off), but when published to SCORM, no captions and no option to turn them on.
  • deb
    deb Community Member Posts: 42 ♪ Opening Act ♪
    Stephen,

    I just got a link to my latest posting and I am still not seeing the CCing in any browser, yet I saw it in the file you exported and posted. Could it be an issue with the server, how it is being uploaded, or something on our end blocking this feature?

    Deb
  • mraines
    mraines Community Member Posts: 3
    Has there been a solution for this? Closed Captions work fine in preview in browser but when published they are not there - or at least the control to turn on English Subtitles. In the code only one LI has been added for "None".  I have tried using all 3 formats for captions, as well as turning captions on by default.   None of these things make a difference. This issue seems to be on both Inspire 17 as well as 18.

    Any help would be appreciated.
  • golchefske3774
    golchefske3774 Community Member Posts: 4
    I am having a similar CC problem as well. When I publish in HTML the CC works in all browsers however when I publish it in SCORM the CC button does not appear in the video interface.  I have the "Use Web Accessibility Settings" checked in the Title Options menu, and I am using the default interface for the video - which is the only one allowed for accessibility.

    Does anyone have a solution to this problem?
  • mraines
    mraines Community Member Posts: 3
    Gene,

    What format are you using for the CC?  For me I was able to get it to work using VTT. For whatever reason SCORM did not like SRT.  Also make sure you are viewing on a server.
  • golchefske3774
    golchefske3774 Community Member Posts: 4
    I am using WEBVTT for captioning and publishing to SCORM1.2. So that doesn't seem to be it for me.
  • golchefske3774
    golchefske3774 Community Member Posts: 4
    Solved - at least for me.

     

    <span style="font-family: 'Calibri',sans-serif; font-size: 11pt;"><span style="color: #000000;"> </span></span>

     
  • golchefske3774
    golchefske3774 Community Member Posts: 4
    Sorry my solution post did not go through, here it is for the record:

    I have been testing all day trying different variations and I finally got the CC button to work on our Pathlore LMS. I was using WEBVTT for the CC which I had read is recommended for use in Lectora. I tried using XML instead and it worked immediately. Thanks mraines for your suggestion, SRT would not work on mraines LMS but VTT did, and for me VTT did not work but XML did.  I guess the takeaway is LMS's don't like certain files for Closed Caption - try until you find one that works.