Questionnaire broken by saving from Lectora 16 to 17?

idak
idak Community Member Posts: 13 ♪ Opening Act ♪
We recently had some problems with a simple questionnaire. Just 20 questions, mostly multiple choice with a few true false and no extra features. The issue was that in some of the true false questions, only one radio button could be chosen no matter what you clicked.

I was beginning to think that it was some sort of problem with my installation, since I couldn't find anyone else in the community reporting the same issue. But then the same thing happened to a different installation.

And now we're getting the same thing to another client.

The common factor was that both of the projects were built with Lectora 16 and had to be updated with Lectora 17.

Is there a way to fix this or we have to make a new questionnaire in Lectora 17 from scratch?

Comments

  • idak
    idak Community Member Posts: 13 ♪ Opening Act ♪
    Forgot to mention, in the first case, the "fix" we found was either just publishing again without changing anything (!) or deleting the specific question adding it again from scratch and publishing again. Sometimes none of those worked. Kind of random behavior.

    The second case is just 5 true false questions and none of them are working, still can't choose what you want. Publishing again didn't work. It's a bit more complex so it's kind of a mess deleting questions...
  • avis7549
    avis7549 Community Member Posts: 12
    Do you view the output in a specific browser? And which LMS are you using?

    Does the error also occurs when you are previewing the items in Lectora itself?

    We had a similar problem that we couldn't click certain answers, it seemed that it mostly was due to LMS settings and the combination of viewing it in IE11 on a LMS with browser restrictions and win7.

    Worked around it by making sure that the LMS had no prefered browser settings.

     

    Good luck!
  • danam
    danam Community Member Posts: 96
    Oh, yeah, we went through this. It was terrible. I copied the survey from the previous year (Lectora 16) and published it for the current year in Lectora 17.  It was the standard questionnaire with short answers and worked really well for us. Everyone loved it. Why mess with a good thing...change the date and a couple minor substitutions for people and such and voila! Right?

    Nope...none of the short answers came through. My boss was livid.

    Lesson learned. Never take anything for granted or run the risk of getting burned. I even saved it as a template because I thought that would be safer and more reliable. Wrong.
  • idak
    idak Community Member Posts: 13 ♪ Opening Act ♪
    Thank you both for your replies!

    The LMS in all cases is SABA. But it had no problem with the Lectora 16 version.

    And the checking was done with IE, Firefox and Chrome with the same results in all browsers in 3 different companies, none of whom had problems with the previous version.

    Guess I have to rebuild the questionnaire from scratch in v.17.
  • idak
    idak Community Member Posts: 13 ♪ Opening Act ♪
    So, I rebuilt the questionnaire from scratch using Lectora 17, but I get the same exact issues. It looks like it's not the conversion from v16 to v17 after all.

    Same thing in both Lectora 17.1.3 and 17.1.5.
  • carlfink
    carlfink Community Member Posts: 968 ✭ Legend ✭
    This is maybe too obvious, but I've had that issue (if I understand you right) because Lectora spontaneously changed the size of the text block containing the question, so that it covered the top option (which thus could not be clicked). This happens because Lectora does not necessarily display exactly the same font in a browser that we see in the development environment.
  • jvalley4735
    jvalley4735 Community Member Posts: 1,357
    Do you have attempts on but with no action?
  • idak
    idak Community Member Posts: 13 ♪ Opening Act ♪
    @jvalley4735 thank you for your reply, Carl was spot on so all is well now.

    @CarlFink Looks like it wasn't so obvious after all! After inserting significant spacing between the text box and the answers, everything worked as intended.

    Then I started reading other threads you posted in and decided to downgrade to version 17.0.6. Now everything works without any guesswork in spacing required.

    Thanks a lot Carl!