Buttons stop working halfway through course after publishing to SCORM

Hi All,

I've recently designed a course using Lectora 17 for my Business and having published to SCORM the Next, Previous, Home and Exit buttons stop working about halfway through the course.

They were working fine on an earlier published version of the course, and all I've adjusted in the new version is the size of some images due to loading times on our work network.

The buttons are defaulted throughout the whole course (i.e. not separate buttons for each page) so I'm confused as to why they've suddenly stopped when they work on the previous page!!??

Any ideas or help would be appreciated.

Thanks,

Phil

Comments

  • mnotermans5114
    mnotermans5114 Community Member Posts: 916
    Everything properly inherited from previous pages ?
    If you share a sample that might help us figure things out.
  • carlfink
    carlfink Community Member Posts: 947 ♦ Idol ♦
    "... I’m confused as to why they’ve suddenly stopped when they work on the previous page!!??"

    How about this random guess: on those pages you have some other object that's higher in the z-order of the page covering them, so the mouse-click event never reaches them? I've done that. You could publish with Debug turned on and see if the event is happening.
  • timk
    timk Community Member Posts: 1,197 ♦ Idol ♦
    If I remember correctly, it's not unknown that transitions may cause issues with buttons.
  • pmurfet3637
    pmurfet3637 Community Member Posts: 3
    Hi All,

    Thanks for your suggestions. I've published with Debug and the next button fires, but doesn't actually do anything. It stops as follows:

    Action [Go to Next Page on Next] fired

    saveVariable for TrivantisEPS to [T]

    Nothing else happens after this. I've tried removing all transitions and still the same error occurs. I've also tried removing the page where the error occurs completely, but it now just happens on the previous page instead (which was originally working fine).

    Unfortunately I'm unable to share a sample due to the confidential content in the course.

    Any other ideas?

     
  • klaatu
    klaatu Community Member Posts: 988
    Yup, make a sample by swapping dummy content for the private content and post.
  • pmurfet3637
    pmurfet3637 Community Member Posts: 3
    Okay thanks - Sorry I'm quite new to posing in the community. I'm assuming I post the SCORM zip file?

    It works perfectly in offline mode, HTML etc. It's just when posting to our LMS that the problem occurs.
  • mnotermans5114
    mnotermans5114 Community Member Posts: 916
    Do post a sample .awt or .pkg so we can inspect and test the course setup on other LMS's. Let us know too what LMS you are testing with. Darrel wrote an excellent post here stating what to do to get adequate help. Browser and LMS you are testing on is important here..

    https://community.trivantis.com/forums/topic/when-requesting-assistance-please-read/

     

    Most basics answers on your issue... is there anything after that next button ? Any other pages ? Else nothing for sure will happen.... and is there an action on that button..do add a message..so you can check whether it triggers or not.
  • rwatkins9162
    rwatkins9162 Community Member Posts: 17
    Hello,

    Ive also noticed this problem, but for me it was a mouse click sound at the title level not playing on some pages. I discovered that in Internet Explorer, our company's default browser, that the issue was consistent. On switching to Chrome as the browser, the issue no longer occurs. Are you running it in IE by chance?

     
  • vvanderroest2732
    vvanderroest2732 Community Member Posts: 1
    Phil - did you find a resolution to this?  I am having the same issue with a course.

    Disregard - I found another post that recommended removing transitions and that fixed my issue.