17.1.2 DIDN'T fix the audio issue!!

cmooraces
cmooraces Community Member Posts: 25 ♪ Opening Act ♪
Since upgrading to 17.1.1 I can't use audio clips. They don't use the default controller I choose. Each browser shows a different controller and there's nothing I can do about it. What's worse is that I really use sync events to bring in elements and perform actions in the audio clip. And NONE of them will work.

Any old file I created can't be published from my Lectora. I have to go to my co-worker and have him publish because he didn't upgrade from 17.0.6.

This upgrade is really bad. I mean really bad.

Comments

  • approg
    approg Community Member Posts: 258 ♪ Opening Act ♪
    I wanted to look into your issue and hopefully resolve it as I couldn't believe that they would break something that so many people rely on. Well, I published a title I create with v.17.0.6 and when I tried to preview it from within Lectora I got nothing but a blank window.

    The browser's error console says "Uncaught SyntaxError: missing ) after argument list".

    Somewhere I have some text that Lectora is supposed to display in a dialog box but the text includes an apostrophe and Lectora's code is wrapping all text in a apostrophes (instead of santizing the text).
  • approg
    approg Community Member Posts: 258 ♪ Opening Act ♪
    If you are using 17.1.2 and you have a page with an action icon with a label that includes an apostrophe (single quote) then the page will fail :-(
  • cmooraces
    cmooraces Community Member Posts: 25 ♪ Opening Act ♪
    In 17.0.6 I can insert an audio file and fire actions throughout the duration of the clip. We've been using this extensively for some time.

    When I upgraded to 17.1.1 and then 17.1.2, any audio clip would cause onshow page actions to not fire. Also, none of the actions that were added to the audio clip would file. Also, the player would not be the one I selected. Chrome had one version and IE displayed a very large player controller that I did not select.

    I reinstalled version 17.0.4 and everything works again. I'm going to patch up to 17.0.6. I don't think 17.1.x is ready for prime time.
  • approg
    approg Community Member Posts: 258 ♪ Opening Act ♪
    Can you upload a small title that demonstrates the issue? I'd like to have a go at finding what the issue is/are.
  • approg
    approg Community Member Posts: 258 ♪ Opening Act ♪
    I built a small sample and the first time I tried it all the actions I'd set in Sync Events had disappeared. I saved the title and set them a second time and this time they stuck.

    BTW the way the "new" Sync Events dialogue looks like a programmer laid it out as a "quick and dirty" layout while they waited for the usability people to design it correctly ;-) In the old days you could see where an event was within the audio wave. Now the only way of checking is to play the audio and watch the time on the timeline and compare it to the event time in the list view.