Auto enrolling Expired Sessions

mreneau
mreneau Community Member Posts: 5
We create a new session for each course every year for updated content (i.e. FY2017, FY2018) and expire the previous years session. This allows the gradebook to track their scores from each year. However, the expired sessions are displaying instead of the current session in the curriculum. We have the auto enroll based on suborgs checked on the course and the AutoReenrollOpenSessionInCurriculums property set to True. We registered the new session based on Suborgs and the course is assigned to the correct suborg but it still is showing the expired sessions. I don't want to unenroll the users in the old session because it will remove the gradebook history. We were able to do this last year without any problems, not sure if Coursemill made changes or what we are missing????

Comments

  • jmaybury9594
    jmaybury9594 Community Member Posts: 1
    We use version 6.8 and are running into the same problem. The person I talked to about it said that it is a bug that will be resolved in the 7.5 version. The only "fix" I have found is to unenroll the user, then re-enroll them in the correct session and manually add their passing score and date. I hope that makes sense. It's very time consuming when you have multiple users with this issue, but according to the representative I spoke with, there is no fix for this outside of upgrading, which is what we are currently working on.

    Good luck!! And please let me know if you come across anything else that may help!!
  • mreneau
    mreneau Community Member Posts: 5
    Thank you so much for replying to the post. It was the most helpful response we have received. I will definitely let you know if we find a different work around.
  • gburdette
    gburdette Community Member Posts: 14 ☆ Roadie ☆
    <p>I seem to be having the same problem.  We were on 6.8 the past few years and did not have any issues.  We upgraded to 7.4 this summer.  Today, I assign suborgs to curricula for 2018 sessions, and it keeps assigning 2017 sessions.  I did check the AutoReenroll property and it was set to No.  But changing it didn't seem to do any good.</p><p>So is this a new bug introduced in 7.4?</p>
  • gburdette
    gburdette Community Member Posts: 14 ☆ Roadie ☆
    <p>I fixed my problem, don't know if it will help anyone else.</p><p>I changed the AutoReenrollOpenSessions... property to Yes and that didn't help.</p><p>Then I remembered to Apply Changes.  That didn't help.</p><p>I tried a whole bunch of other things.  Then I discovered there is a "Known Issue" that properties aren't actually getting changed until the admin logs out and back in.  I had been logged in continuously all afternoon trying to fix it.</p><p>After I logged out and back in, my curricula were assigning to the correct (open) sessions.</p>
  • mreneau
    mreneau Community Member Posts: 5
    We did change this property as well and it appears to work when you remove the course and add the course back to the curriculum. However, when the nightly batch runs it assigns the expired session again. We have found a work around since it will only assign the expired session to the users that did not complete the course. We have used the Bulk Unenroll Users to unenroll the users in the session that is expired and not complete. An easy way to create the import is to run the status report for incomplete/not attempted courses. You will need to change the import headers and remove the session title and only keep the ID of the session to unenroll the users but it gives you all of the data in the report. Not a fun work around and we are hoping with the upgrade to coursemill that this bug will get fixed.