Navigation to post-test not working in Lectora 17

sjones Community Member Posts: 39
I created a course using Lectora Inspire X that has an introduction page before the post-test. The user would click the next button to navigate to the post-test  to begin answering the questions. This worked when reviewing the course throught Lectora X or publishing to HTML or offline.

The course has now been upgraded to Lectora 17 without any changes to the basic functionality (used a previous version of the course as the template).  When reviewing the course in Lectora 17, the next button on the post-test introduction page does navigate to the post-test questions. However, when the version 17 course is published to HTML or offline, the next button does not navigate to the post-test questions.

The course is not tested on the LMS until reviewed in HTML or offline format. If the course functions correctly in these formats,then the course is uploaded to the LMS and tested before being available.

Any hints and/or suggestions would be most welcomed.


  • struitt
    struitt Community Member Posts: 138 ♪ Opening Act ♪
    First thing I would try would be to add a new Next button on that page just for testing.  If it works then you may want to remove the 'old' Next button and replace it.

    Also - I've noticed sometimes that when something Lectora is copied and pasted it may clearly show 'On Click Go To Next Page,' however it appears to be daydreaming (for lack of a better term).  If that is the case simply use the drop down and select 'Next Page' to sort of 'reset' the action.
  • timk
    timk Community Member Posts: 1,245 ✭ Legend ✭
    Migrating a course from Lectora X to v17 means skipping 3 full versions that included lots of major updates. If I remember correctly especially the transfer of a course from X to 11 was a lot of work.

    Doesn't the error check or publishing process display any errors? Although a Go to action that has lost its target will display "Next page" instead of nothing in the action properties, it should produce an error message.

    Is the Go to action the only action on that button? Is it the last action?
  • mnotermans5114
    mnotermans5114 Community Member Posts: 916 ☆ Roadie ☆
    I do have worked in X6 -> L16 -> L17, still even have courses in X6 that now and then need to be updated. No big issues so far. If you can send a stripped down version of your courses we can check whats going wrong.
  • sjones
    sjones Community Member Posts: 39
    Thank everyone who replied.  however, I found out why the course was not advancing to the Post-test:

    I had 2 chapters with the same title "Post-test", one chaper contained the introductory material for the test and the other contained the questions, so I made sure that the names were different.  Running the program within Lectora everything works correctly navigating to the Post-test.

    HOWEVER... there are two other items that I don't understand

    The way this version of Lectora works when reviewing is very different from v10. It appears that the program creates or becomes a  "virtual" website and the course functions as expected, but if  I  try to run the html rendered version with the program closed, no navigation to the post-test.   In v10, one could run the entire course from the html folder without having Lectora open.  This is a problem when others on the team are QAing the course;  they do not have Lectora 17 installed on their systems.

    One last "problem", how can one reset the variables to their initial value in the offline version....I've tried to delete the cookies in IE but have no clue about Edge....

    Any help is most welcome!