Healthstream SCORM Publishing

I am new to Lectora and I have taking the Funamentals and Intermediate classes but I am still having trouble with a course. I have a course I have built and including just a simple 1 question test. I published the course to SCORM and uploaded the zip file to Healthstream. When I run the course through Healthstream it goes through the process but once I get to the question and answer it properly then click the Done button it doesn't finalize the course. It closes out the window and says the course is still in progress. Can someone tell me what I could be missing?

Comments

  • jvalley4735
    jvalley4735 Community Member Posts: 1,357
    Is your test set to be graded on the Results ribbon? Do you have an action in your test somewhere to process the test?
  • kbrower1440
    kbrower1440 Community Member Posts: 4
    I do. I think I figured it out. I had to place the lesson status modified variable action to the last page.
  • jvalley4735
    jvalley4735 Community Member Posts: 1,357
    Great!
  • kfinn9162
    kfinn9162 Community Member Posts: 2
    I am having the same issues- I have a test, which is graded and on the last page, set the modified variable to lesson status complete, but the course still won't "complete" in HealthStream.  This isn't as simple as I had hoped it would be-
  • jvalley4735
    jvalley4735 Community Member Posts: 1,357
    How is the action triggered?  On page show?
  • kfinn9162
    kfinn9162 Community Member Posts: 2
    Yes- I finally figured it out!  Things are going much more smoothly now.
  • kbrower1440
    kbrower1440 Community Member Posts: 4
    Yes it is triggered as on page show
  • astafford3593
    astafford3593 Community Member Posts: 12
    I'm having issues with Healthstream as well. I created a test with five questions. Once a learner gets to the completed page, I have three variable set up to update my information in Healthstream.
    • On page show>Modify Variable>AICC score >set equal to> 100
    • On page show>Modify Variable>AICC lesson status >set equal to>completed
    • On page show>Modify Variable>CMI_Completion_Status>completed
    When I publish the zip file into Heathstream and run the course, I receive three pop-up errors when I click the next button on the last test question. The next button has one action set and its to process test on mouse click. If I click ok on the errors, I'm able to go to the completion page and finish the course. Once I'm back in HealthStream, everything updates, completes, and score shows 100%

    Any ideas on why I'm getting pop-up errors while I'm in the course? Attached are images of the errors.

    I appreciate all and any help. Thank you!
  • timk
    timk Community Member Posts: 1,195 ♦ Idol ♦
    Which Scorm version do you publish to? ... and does Healthstream support this version?

    The AICC_Score action should be alright - is there a reason why you don't use the test score for the AICC_Score?

    AICC_Lesson_Status is Scorm 1.2, CMI_Completion_Status is Scorm 2004, you should remove the action that doesn't match the Scorm version you publish to.
  • astafford3593
    astafford3593 Community Member Posts: 12
    Tim, thank you for your response. It's been awhile since I've worked in Lectora with tests/quizzes. For some reason, I thought I needed to add an action to the completion page, but maybe I'm getting that mixed up for when I don't have a test. Do I need to create an action for the test score to show in Healthstream or does the process test action do that for me?

    When I publish the course, it defaults the SCORM Options in Lectora to SCORM 1.2 - I didn't even think to check if Healthstream would support that file time. I will try to track this information down. Is this what you're referring to when you asked what version I publish?

    Thank you so much for your help!

     
  • timk
    timk Community Member Posts: 1,195 ♦ Idol ♦
    Scorm 1.2 should be ok, it's rather 2004 that's not generally supported.

    You can try to remove the action modifying cmi_completion_status (see Capture3)

    In the publishing settings uncheck "The published course will report Test / Survey Question Interaction to the LMS" (see Capture1 and 2)
  • astafford3593
    astafford3593 Community Member Posts: 12
    Tim - that fixed my issues. Thank you so much for your help!