Lectora 17's "Publish for Seamless Play" Not So Seamless :(

tecocat
tecocat Community Member Posts: 389 ♪ Opening Act ♪
I recently created a new title in Lectora 17 and, today, I published it to ReviewLink to test it. However, when I ran it, all I got was a blank window (except for the ReviewLink banner at the bottom that displays the title of the course, etc). I then tried publishing it locally to HTML and, when I ran it in my browser (tried both IE and Chrome, with the same result) all I got was a blank window and the address bar said "http://localhost:3750"

Because it was a new feature, I decided to see what would happen if I turned off the "Publish for Seamless Play" option and, sure enough, my title then published and ran just fine.

I don't know what it was in my title that was making this option unusable, but I'm pretty disappointed about that, because I was really looking forward to doing away with the annoying "white flash"! But I thought I'd at least post this in case someone else is having the same problem, so they can see how to "fix" it (at least until the Seamless Play feature itself is fixed).

Comments

  • timk
    timk Community Member Posts: 1,197 ♦ Idol ♦
    Hi Laura,

    how did you open the published title locally? You can't just publish and open the index.html from the folder any more, because Lectora 17 now uses a virtual server to display the pages. Try to publish and start the course with the "Preview" button in the bottom center of the publishing dialogue.

    I've tested quite a lot with "Seamless play" both separately and with real projects and from my experience it is working. Can't tell why it won't work with your file. Can you share?

    Tim
  • tecocat
    tecocat Community Member Posts: 389 ♪ Opening Act ♪
    Hi, Tim -

    Yes, I used the Preview button you described, plus, as I mentioned, it didn't work in ReviewLink, either. (And I tried accessing it in ReviewLink both from the ReviewLink option after publishing and from within ReviewLink itself.)

    I can't share the file publicly here, as is, because of proprietary info, but maybe if I have some time, I can strip out the contents of the text blocks and any sensitive images and remove some of the functionally repetitive pages and upload that. I do have a few HTML objects in it (most ones I've been using forever and one that I just started using....the one you helped me with! :) ).

    I'm eating a very late lunch now, so let me see if I can create the new, stripped out version while I eat.

    Thanks for caring!
    Laura

    P.S. That's bummer about not being able to run from the index.html file anymore...does that mean that, if I'm doing local testing and I close the window by accident, I'd have to republish each time to run it again? If so, not cool....
  • tecocat
    tecocat Community Member Posts: 389 ♪ Opening Act ♪
    Okay - I'm attaching a stripped-down version, which I've published to ReviewLink with the Seamless Play option selected and confirmed has the same problem as my original one.

    (Please don't judge the look of the course or anything...I had to strip out a bunch of stuff, so it doesn't really look right anymore.)

    I'll be interested to hear if you see anything that might be causing that problem (especially if it's something I can fix without losing any of the functionality I put in it)!
  • timk
    timk Community Member Posts: 1,197 ♦ Idol ♦
    I've taken a look at your file, both locally and on ReviewLink and both ways Seamless Play seems to be working alright. If you liked, I could invite you to my ReviewLink account, for you to see whether it makes a difference, but there's no email adress in your profile?

    With regard to P.S.: I don't know for sure, but currently I'm republishing when I closed the window.

    @jvalley4735 I'd like to suggest adding a button "Open html-published content" somewhere, that does the same as the "Preview" button, no problem with calling it "Preview" as well ;-), only so we don't have to republish.

     
  • tecocat
    tecocat Community Member Posts: 389 ♪ Opening Act ♪
    Well, that's weird that it works for you, but not me (yet it works for me when I publish without that option selected). Which browser were you using? I tried IE 11 and Chrome 54.0.2840.99 m (thank goodness for copy and paste on that one, lol!).

    My email address is lagil at sunlife dot com, if you want to invite me to your ReviewLink. (If you don't hear from me before Monday, it will be because I signed off before I had a chance to see your invitation.)

    Thanks, again, for your interest and for trying it out for me! :)
  • timk
    timk Community Member Posts: 1,197 ♦ Idol ♦
    I tested locally with Firefox 53.0.2 and IE 11. more numbers following but no option to copy...

    With ReviewLink IE 11 only, as I'm not able to login to ReviewLink on Firefox any more.

    If you don't hear from me, I'll be on vacation next week and off to the Netherlands and the ocean.
  • tecocat
    tecocat Community Member Posts: 389 ♪ Opening Act ♪
    Well, here's a little interesting "rub".... When I got your invitation, I clicked on the link and it wanted me to log in. But, when I logged in, I was at my own dashboard....how do I get to "your" ReviewLink? The link in the email looked too generic...it didn't seem to have anything that would indicate to RL that it should go to your area of it... (I've attached a screen capture of the relevant part of the email I received.)

    Enjoy your vacation...sounds lovely!!

     
  • timk
    timk Community Member Posts: 1,197 ♦ Idol ♦
    I hardly tested ReviewLink from the Reviewers perspective, shouldn't the course I invited you to be accessible from your dashboard? Does it make a difference where you're located?
  • timk
    timk Community Member Posts: 1,197 ♦ Idol ♦
    When you open ReviewLink you'll probably see the "My published content" tab. Check the "My Content to Review" tab.
  • tecocat
    tecocat Community Member Posts: 389 ♪ Opening Act ♪
    Lol - I had just figured that out and was composing a reply to that effect when your second comment came through.

    Can't believe I didn't notice that....guess that's what happens when you're trying to do stuff late on a Friday of a looong week!

    At any rate, I have the same problem when I try to view the version you published to ReviewLink. It's odd that, given that we're both using the same browser, you can view it with Seamless Play on and I can't! But I guess that will be good food for support, if I end up deciding to contact them about this.

    Thanks again! :)
  • timk
    timk Community Member Posts: 1,197 ♦ Idol ♦
    ;-) My "Content to Review" tab is usually empty also, as I'm only publishing for other people to review. Do contact support, from my experience they are very very helpful, fast and friendly, anything you could wish from support. But now, midnight where I am, need some sleep...
  • jvalley4735
    jvalley4735 Community Member Posts: 1,357
    @timk A full HTML preview instead of the single page?
  • jvalley4735
    jvalley4735 Community Member Posts: 1,357
    Laura, do you have any external HTML in your course?
  • tecocat
    tecocat Community Member Posts: 389 ♪ Opening Act ♪
    @jvalley4735 - Yes, I have a couple minor ones at the title level -- one to prevent the image toolbar from popping up when someone mouses over an image and one, that, now that I think of it, may be the problem, since it had to do with page transitions! I think I'll try deleting that one and see if it fixes the problem.... I also have a new one on just one page, which allows the printer to see the whole page, even if the content needs to be scrolled to view it on screen. (You probably noticed the forum conversation that got me that little gem! :) ).

    So, I'll try deleting that page transition HTML (which is just one line:  <meta http-equiv="Page-Enter"content="revealTrans(Transition=12,Duration=0.01)"> ) and see if that makes the difference. I'm embarrassed to admit that I don't even remember for sure what it does...I think it was an attempt to make the pages load more smoothly and the items load together more. I got it from someone here a while back and have been using it in all of my courses ever since. (I really hate the way the pages load....the images, even if they're small, non-photo ones, almost always come in after the text...I'm hoping that this new feature will make page loads smoother and more "professional" looking.)

    Thanks for that thought though....feeling a little dumb that I didn't think of that myself! I'll report back after I try deleting it and re-publishing with Seamless Play on and let you know whether that fixed the problem.
  • tecocat
    tecocat Community Member Posts: 389 ♪ Opening Act ♪
    @jvalley4735 - Alas, after removing ALL external HTML items (all three of them), it still won't publish properly with Seamless Play selected. :(

    When I get a chance, I'll send this over to support, I guess. However, Tim didn't have a problem publishing it with Seamless Play, so there must be a problem on my end, although I can't guess what it could be, since it doesn't work with two different browsers.
  • jvalley4735
    jvalley4735 Community Member Posts: 1,357
    It could be a different in between operating systems...sometimes that can cause two computers running the same browsers to display differently.  I doubt it's the difference in location (your east coast US and he's Europe) but I've seen stranger things. If the issue isn't duplicatable send it over to Support.  They'll hopefully be able to find the right combo of testing to figure it out :)