actions not playing video or audio on ipad or phone

kraven7771
kraven7771 Community Member Posts: 50
I was wondering if anyone else is having this issue on ipad and phone,

After my page is done playing it's audio or video, the user is able to click on another button to allow another video or audio to play on the same page. Everything will show up like it's supposed but the audio and the video won't play until I press the play.

Anyone else having this issue with button's actions not playing a video or audio on command on mobile devices? or aware if there might be some kind of bug or need a specific action to allow this?

This works perfectly fine on desktop.

Comments

  • krodgers6170
    krodgers6170 Community Member Posts: 25
    Hi KC,

    With Tablets and Phones, I feel like I have to assign extra actions to get the desired functionality.

     

    So to get your audio and video to play, I would assign four actions to the button:
    • OnShowShow Target= Video
    • OnShowPlay" Target= Video
    • OnShowShow Target = Audio
    • OnShowPlay Target=Audio
    Or, You could assign two OnShowShow actions  to the button for each the video and audio and then assign one action to each the video and audio
    • Video
      • (Action OnShowPlay Video)
    • Audio
      • (Action OnShowPlay Audio)
    You may also want to take a look at how the page objects are layered in your title list. For videos that are not initially visible, I will typically add to the property "Always on top" to ensure it appears.

     

    Hope this helps,

     

    Kelsey
  • kraven7771
    kraven7771 Community Member Posts: 50
    thanks Kelsey

    I'll give that a try
  • jvalley4735
    jvalley4735 Community Member Posts: 1,357
    The functionality (on done) doesn't work on most mobile devices because of restrictions put into place by phone providers and developers (i.e. Apple).  However, it now works in the latest version of our product (Lectora 17: Check it out here http://trivantis.com/products/inspire-e-learning-software/).
  • kraven7771
    kraven7771 Community Member Posts: 50
    Thanks for the heads up Jennifer.

    At the moment I'm stuck on the Online version; are you aware of anything that could possible be keeping an audio or an video from playing when a button is clicked? I'm struggling to figure out why on some slides they play and others they don't when it comes to the ipad and phone.
  • jvalley4735
    jvalley4735 Community Member Posts: 1,357
    Sometimes it can be the file extension.  Can you try converting the audio to MP3 and video to MP4 to see if that makes a difference?
  • kraven7771
    kraven7771 Community Member Posts: 50
    all my files are either mp3s or mp4s

    For some weird reason, some play without issues, and others don't when they're supposed to be activated by an onclick action.
  • kraven7771
    kraven7771 Community Member Posts: 50
    yay!

    we switched lectora 17.

    I'm running into a weird issue though, with the videos on mobile devicious are showing a video controls. Do you know of a way to turn this off?
  • jvalley4735
    jvalley4735 Community Member Posts: 1,357
    The video controller can be updated by going to the Video's properties and selecting the various options from the Playback group