Omit Chapters from the TOC Menu

ecollins3413
ecollins3413 Community Member Posts: 3
Using Lectora Online (Trial)

Menu Creator:

The program contain six chapters with multiple pages. the 7th chapter (response chapter) contains two response pages. The response chapter should not show on the menu.

In the Menu Creator, I click the visibility checkbox to remove the "response" chapter from the list and the "response" chapter is removed from the menu. When I preview the module, the "response" chapter is not on the menu. I click a menu item to take me to that page then click the menu link to return to the menu, the "response" chapter is now visible on the menu.

The menu object is on the title page under the Book level.  The "Menu" text-link is an object on the Book level and is targeted to the Title Page. Bottom line is the "response" chapter and/or pages should never show on the Menu as a menu option. Don't think it matters but the "Menu" transitions in and out of the page.

Is this issue related to the trial version or is it systemic to Lectora?

Comments

  • jvalley4735
    jvalley4735 Community Member Posts: 1,357
    In order to show or hide pages in your menu you'll need to navigate to it's Properities and select the Included Pages check box.  From here you'll be able to de-select the Response chapter.  Once you save and preview the course again it should no longer appear.  If you've already done that and it's not working can you share the files so I can take a look?

    http://trivantis.com/help/Lectora_Online/3.1/en/HelpHTMLs/index.html#2223.html?TocPath=Managing%20titles|Working%20with%20objects|Working%20with%20menus|_____4
  • ecollins3413
    ecollins3413 Community Member Posts: 3
    Hi Jennifer,

    Thank you for your response. Yes, I have already used the Included Pages option. I've tested with the pages included and without the pages included. When I click the save button, the "response" option returns to the menu. How can I share the files? Add you as a user?
  • jasonadal
    jasonadal Community Member Posts: 441 ♪ Opening Act ♪
    I want to piggy back on this as I think it may be applicable in both online and desktop.

    Is there a way to hide the listing for the Assignable Unit in the TOC other than moving the main content out from under the AU?
  • jvalley4735
    jvalley4735 Community Member Posts: 1,357
    You can share the files by uploading them as an attachment in the community (if you don't mind sharing them publically) or sending to them via email using a file sharing software (I recommend WeTransfer but DropBox works too). There is a size limitation in the community where you can't share above 102,400 KB.  If either of those options don't work then you can always submit your issue into Support since they have a large uploader attached to the form.  It can be accessed by selecting the Submit a support ticket button above.

    @JasonADal When I have a course with an AU, chapters, sections and pages even if the AU is selected it's not showing up in my course when I preview or publish.  What version are you running?  How are you previewing?  And can you share your files?
  • jasonadal
    jasonadal Community Member Posts: 441 ♪ Opening Act ♪
    Jennifer - I figured it out. I had the TOC above the AU in the Title Explorer and when I moved it down as part of the AU instead of the overall title, the AU no longer shows in the TOC. I can't recall my rationale for having it as part of whole title except perhaps to more easily include it on the test section.
  • jvalley4735
    jvalley4735 Community Member Posts: 1,357
    Good to know!