Embed font into project

kraven7771
kraven7771 Community Member Posts: 50
Hi, i'm new to lectora and I've been struggling to get my fonts to embed.

I've tried every tutorial I could find to try and figure out what I'm doing wrong. I'm using Lectora Online 3.0, I don't know if maybe there's a different way to embedded fonts with this version from what I've been trying.

I've added the css script to a html extension, and font files to the Additional Files.

I've also added the font names to the User Fonts on the home page, but even though the items are in the list, they don't show up as their correct fonts. Even when I test in browser mode the font are incorrect.

At this point I've extremely clueless to what I could have misses to connect everything together.

 

I've attached images of what my set up looks to try and get them to embedded.

 

Comments

  • ssneg
    ssneg Community Member Posts: 1,466 ☆ Roadie ☆
    Please find a quick demo attached. Share your project/sample if you'd like me to take a look.
  • ssneg
    ssneg Community Member Posts: 1,466 ☆ Roadie ☆
    Oooops, I noticed a big mistake in your screenshot. The font-face stuff should be wrapped in "STYLE" tags, not "SCRIPT" tags. This is why it is not working I guess.
  • ssneg
    ssneg Community Member Posts: 1,466 ☆ Roadie ☆
    Also, I think font-family declarations must be quoted, e.g. font-family: "BMW Bold Italic";
  • kraven7771
    kraven7771 Community Member Posts: 50
    Thanks, it was the <script> tags.

    I don't know how i didn't notice that earlier.