Multiple Response Questions Not Working?

vicki
vicki Community Member Posts: 75 ♪ Opening Act ♪
I updated to 16.2 last week.

I have an interaction that uses a combination of multiple choice and multiple response questions. When I run the interaction in Preview Mode or Preview in Browser (IE & Firefox), the multiple choice questions are processed correctly, but the multiple response are not. The multiple response are always processed as incorrect.

Since the multiple choice questions are working correctly and all the questions have the same actions, this leads me to believe that the issue is with the multiple response questions.

Is anyone else experiencing this or something similar?

Thanks!

Comments

  • jvalley4735
    jvalley4735 Community Member Posts: 1,357
    There was a high volume of issues associated with 16.2. If possible I would try downloading 16.2.1 and seeing the issue still happens.  You can find the download files here http://trivantis.com/service-pack-downloads/ or select the auto update options from within Lectora.  Since it was just released today it might not show up right away.
  • vicki
    vicki Community Member Posts: 75 ♪ Opening Act ♪
    I had downloaded and installed 16.2.1 first thing this morning. It did not fix the issue.

    I will probably reinsert the question from scratch to see if it is a version issue.

    Thanks!
  • vicki
    vicki Community Member Posts: 75 ♪ Opening Act ♪
    Here is an update. After working with one of your AWESOME support folks (Thanks again, Fred!)...the multiple response questions have a couple of bugs.

    First bug...if you have actions linked to a multiple response question in an external group, they don't recognize the question. In my interaction, once the answer button is selected, an action group of feedback actions is fired. Within those feedback actions are actions that require IF the question is correct/incorrect. The feedback is in another group. The test question was not being recognized as correct so the incorrect actions would be run.

    The fix was to use the built-in question feedback to have my correct/incorrect feedback show and remove the actions from the feedback group. However, now my counter of questions correct is not working since the question is not recognized as correct.

    Second bug that we found during problem solving of the first...if you have two answer choices that are the same, if you select one of the answers, Lectora automatically selects both. For example, as we set up test questions to try different orders of actions, we put in a simple multiple response question with the answers Yes, Yes, No (so you can easily know which answers were correct). If you selected one of the Yes's, both would become checkmarked.

    Anyhow, attached is a screenshot of one of the questions with the solution on recognizing correct/incorrect already applied. Now to tackle the counter. WooHoo!
  • vicki
    vicki Community Member Posts: 75 ♪ Opening Act ♪
    As an update to my update (and I am proud of myself for figuring it out)...

    The counter is now working. I put in actions to change the count and update the text box when the Correct feedback shows.

    The inability to use random question selection based on whether the question was previously answered correctly or not was addressed by adding another action to the Correct Feedback box that assigned the question a variable. If the question has that variable it won't show again.

    Patting self on back. Have a great day all!
  • rwalters
    rwalters Community Member Posts: 276
    What I had to do for multiple response questions is use the question variable, the "equal to" or "not equal to" relationship and then input the exact answer to the question (which should look like "answer one,answer two" with no spaces before or after the comma and of course no quotes).