Error Message: LMSSetValue Error

jblochowiak
jblochowiak Community Member Posts: 18
I just published a file and when I put it into our LMS, I get the following error: LMSSetValue Error: smi.interactions.1.text to [ ] Incorrect Data Type.

I've never had this error message before. Any suggestions?

 

Comments

  • ssneg
    ssneg Community Member Posts: 1,466 ☆ Roadie ☆
    You can try disabling interaction reporting in the Publish options.
  • jblochowiak
    jblochowiak Community Member Posts: 18
    If I make that change, how will the LMS get the passing score?
  • krodgers6170
    krodgers6170 Community Member Posts: 25
    Hi there,

    I have gotten that error message when I incorrectly added and modified a variable to my title and it appeared in the mobile output (when I tested on an iPhone). I believe I added the CMI_Completion Status variable but that is only for SCORM 2004 outputs.

    Are you working with a published SCORM or API (xAPI) project?

    Which variable are you using in your title track the passing score?

    For SCORM:
    • I would recommend using the AICC_Lesson_Status variable to tell the LMS that the training is completed
    • I would recommend using the AICC_Score variable to tell the LMS the average of all the test scores in the title
    I am not sure if it is the same for an xAPI output...

    Go through the variable manager and read each of the descriptions for the Reserved variables- that also helps.

    Kelsey
  • ssneg
    ssneg Community Member Posts: 1,466 ☆ Roadie ☆
    If I make that change, how will the LMS get the passing score?
    Passing score is not communicated via interactions. So nothing will change in that regard.
Sign In or Register to comment.

So You Wanna Be An eLearning ROCKSTAR?

We're all fans of eLearning here! Want to become an eLearning ROCKSTAR? Just click on one of the buttons below to start your rocking journey!