File Association - not there i nv16

carlfink
carlfink Community Member Posts: 1,102 ✭ Legend ✭
So since installing version 16, double-clicking an AWT file does not launch Lectora. Windows (version 7) prompts me to select a program. Selecting Lectora doesn't actually cause Lectora to launch and load the file. I can open all these same files using File>>Open from within Lectora.

Is anyone else experiencing this? Is it perhaps an artifact of upgrading from V11?

Thanks.

 

EDIT: wow, I typed the word "in" wrong. Sorry.

Comments

  • jvalley4735
    jvalley4735 Community Member Posts: 1,357
    Did you install 16 before or after uninstalling 11?  It sounds like the system lost it's association. This happens quite often when you download 16 and then uninstall 11.  I would first suggest right clicking an AWT, select open with, and then choose default program.  Select Lectora 16 from the list of programs.  If that doesn't work you'll need to uninstall and reinstall.
  • carlfink
    carlfink Community Member Posts: 1,102 ✭ Legend ✭
    I have tried manually setting the association. As mentioned at top-of-thread, this doesn't work even one time. I've also reinstalled.
  • jvalley4735
    jvalley4735 Community Member Posts: 1,357
    According to a member of support it may be because you're lacking the proper permissions to make the change.  Can you run as an administrator?  Here's an article with instructions: http://community.trivantis.com/knowledge-base/lectora-file-associations/
  • carlfink
    carlfink Community Member Posts: 1,102 ✭ Legend ✭
    Running as administrator had no effect. The instructions don't work because Lectora is not listed as an option, and if I navigate to and select lectora.exe from c:\Program Files (86)\Trivantis\Lectora Publisher, Windows ignores that and still doesn't list it as an option or launch the file.
  • jvalley4735
    jvalley4735 Community Member Posts: 1,357
    Is there a way to get your IT department involved in the install? The instructions and association should be working.
  • carlfink
    carlfink Community Member Posts: 1,102 ✭ Legend ✭
    It's enormously difficult to get any non-standard service from our IS department, and I am a local admin on this laptop in any case.

    It's probably easier for me to continue just using File >> Open. I just wondered if others were experiencing similar problems. Thanks.
  • jvalley4735
    jvalley4735 Community Member Posts: 1,357
    I understand! There were others having issues when 16 was first launched but it was mostly do with what I described before.  Hopefully someone can comment on this and maybe help you find a resolution.
  • dpeteranderl9908
    dpeteranderl9908 Community Member Posts: 10
    I struggled with the same problem and found a simple solution.
    1. create a new empty text file on your desktop and replace the file ending ".txt" with ".awt"
    2. double click the fake AWT file you just created
    3. when you're prompted to choose a program to open the file with, manually pick "C:\Program Files (x86)\Trivantis\Lectora Publisher 17\Lectora.exe" (just like you did before)
    4. you should now be able to choose Lectora as default program to open .awt files with. Do so.
    5. you're done. All .awt files should now be associated with Lectora
    6. (as the file is a dummy, there's going to be an error message as soon as you actually open it with Lectora. Just click OK and open the file you actually want to edit)
    I think this has to do with where the file you're trying to associate with Lectora is stored. In my case the file wasn't locally stored but within our network. This seemed to be the issue ... as soon as you do this with a local file, everything should work fine. Hope I could help.
  • carlfink
    carlfink Community Member Posts: 1,102 ✭ Legend ✭
    Good catch, Dennis. Lectora in general seems to handle networks weirdly (you can't reliably work on a course that's saved on a network drive) so I'm not shocked that Windows also can't handle it. Are you also using Windows 7?
  • dpeteranderl9908
    dpeteranderl9908 Community Member Posts: 10
    Windows 10 ... Did it work for you?
  • klaatu
    klaatu Community Member Posts: 988
    Try this:

    ype "control panel" without the quotes in the Cortana search box. The best match should be the control panel app. Select it. Now select "Associate a file type or protocol with a program". A new window will open (it might take a few seconds). On the left scroll down until you find .awt. It should have 'Lectora title' as the description and 'Lectora Inspire' as the current default. Regardless, because you're having a problem with the association highlight that row (.awt) and click the change program button (near top right). If Lectora Inspire is not one of the initial options select "more apps". You might have to scroll all the way down in this window and select "look for another app on this pc". Navigate to the Lectora.exe and select it to make it the default.

    You may need to log out and back in to windows for this to take effect.
  • dpeteranderl9908
    dpeteranderl9908 Community Member Posts: 10
    Hi Darrel,

    We've found a solution already. Thanks nonetheless!

    I've already tried your approach before that. For some reason, however, when I searched the filetype list for .awt it was nowhere to be found. I think it had to do with me having all my Lectora projects on network drives. In the end, associating a locally saved file with Lectora solved the problem.
  • carlfink
    carlfink Community Member Posts: 1,102 ✭ Legend ✭
    I can't test your method, Dennis. I just ended up directly editing the darn Registry, IIRC.