MP3 files not playing/properly recognised

mlapl1 Community Member Posts: 350 ☆ Roadie ☆
Hello I have been playing intermittently with Lectora so it is probably something I have done wrong.

Also... it may be something peculiar to my PC. But...

I have been working with audio recordings (MP3) with Lectora 12.1 for some time with no proeblems. Until this morning. My audio files suddenly stopped working when I tried to play them with a button (or anything else actually).

I started a brand new course and imported an MP3 into the course. It seemed to import correctly, except that the player controls do not appear as I would normally expect them to appear. Instead, all I get is an outline of the player and the audio file disappears from view if I click elsewhere. I could change the controller to the speaker icon and that remains visible, but I still cannot play the file. I also cannot play the file with a button.

If I try to insert a .wav file, it creates a player (apparently based on VLC the default player for all media files on my machine). It plays the audio once and then no more.

I am using Windows 7 Home Premium 64-bit SP1.

Everything was working perfectly until a couple of hours ago. I have restarted the PC and also reinstalled Lectora but to no avail.

Has anyone experienced anything similar?

Thanks for your help




  • mlapl1
    mlapl1 Community Member Posts: 350 ☆ Roadie ☆
    I have tried to update the above post but the system insists I add files and other stuff. Anyway...

    PS I should add that I have experimented a little more and the problem does NOT occur when I publish the lesson to my localhost (Vertrigo web server). It seems to occur only in the Lectora Preview modes. I have not tried a commercial server yet.
  • mlapl1
    mlapl1 Community Member Posts: 350 ☆ Roadie ☆
    Solved (more or less).

    It turns out that Flash player is the culprit. If you automatically updated to version - you will have problems of this kind and similar ones. The answer is to uninstall this player and install an earlier version of Flash player. Apparently this problem does not affect Win8 or Win10 - but only Win7 and Vista.

  • awomble
    awomble Community Member Posts: 4
    I began experiencing this problem just today as well.  Thank you for posting your resolution!
  • jcristol
    jcristol Community Member Posts: 11
    I'm so glad I looked here first before I started to freak out. I experienced the same exact problem this morning. I thought something was wrong with my recording (which is the same as ALL of the other ones). Thank you for figuring out the issue.
  • jvalley4735
    jvalley4735 Community Member Posts: 1,357

    Official update: On December 28, 2015, Adobe released an update to their Flash Player which contains a bug that is affecting the performance of all Flash content loaded through the Flash ActiveX control, including several Flash based objects and features used within our Lectora product.

    Specific known conflicts from this bug in Adobe's Flash Player include:

    • Audio and video files that use Lectora's built-in media player as well as any Flash animation (.swf) files in your title will not load and play in Edit, Run, and Preview modes as well as Publish to Offline (CD/EXE).
    • The eLearning Brothers Interaction Builder in Lectora will not load successfully.

    Adobe has assigned this bug a Priority 4 - Very High rating and has advised that their development team is working on fixing this issue.

    Until Adobe has resolved this issue, you can access the eLearning Brothers Template Library and Interaction Builder at Log in with your existing credentials to create new course assets. You can also access any saved files you have already created. Download and then drag and drop the Lectora library object into your title.

    You may also continue to develop and publish titles containing audio, video, and Flash animations as they will function correctly in any web-based publish (HTML, ReviewLink, SCORM, AICC, and xAPI).

    If you have any issues accessing your eLearning Brothers credentials or have questions regarding this issue, please contact Trivantis support.

  • lmission
    lmission Community Member Posts: 7
    I am also experiencing the same issues on Lectora 11 in a Windows 10 environment.

    I am in the middle of a project that uses .mp3 files as part of the feedback mechanism for quizzing and yesterday night I could no longer play, preview or use Action to play any of these files.

    This is a very bad time for Adobe to make this update because I have a product delivery deadline within a week.

    Please let me and all of us know when Adobe fixed this issue and pushes an update.

    BTW.  I tried uninstalling the latest Flash Player version but am not able to downgrade.  Please give detailed instructions on what YOU did to do the uninstall and the install of the version that works.  I've read the Adobe directions already but really need help on the installation (which version should I use anyway?).

  • mlapl1
    mlapl1 Community Member Posts: 350 ☆ Roadie ☆
    Hello @lmission. I have sent you a private message about this.

  • nwilliams3743
    nwilliams3743 Community Member Posts: 74
    Has this been resolved yet?

    Currently experiencing issues.  Have an audio file, must be invisible and actioned to play clicking on a button, but no sound is playing.

    If I understand the above correctly, this will work fine when published, however not in run, edit and preview mode?

    Wanted to avoid starting a new thread on an already recognised issue.

  • jcristol
    jcristol Community Member Posts: 11
    Try updating your flash.