VR Course Contest


Show us your best virtual reality course and win $50 gift card and a winner badge!
CHECK IT OUT

Lectora HTML not submitting results

Hello,

I have created content that will not require an LMS as all results are being submitted to Google Drive, I have published the content and when I try to play the index file it works brilliantly... however once I get to the last test page where the test is marked and then redirects the learner to either a pass or fail page it doesn't work. (The button is click-able but just doesn't execute the action)

It works in Lectora and works in LectoraViewer (Offline Publish) but as soon as it is played through Google Chrome or IE every button works apart from the last.

Any help/ideas to work around?

Many Thanks,

Craig

Comments

  • timk
    timk Community Member Posts: 1,147 ✶ Headliner ✶
    What exactly do you want the button to do?

    You have to publish with "Include title manager frame" checked. Although it can be unchecked in a not-randomized test, (from my experience) it's definitely needed to make a test work properly.

    Tim
  • amwdmw
    amwdmw Community Member Posts: 97
    I am having this same problem.  I publish in html and in the offline version of html (zip files), and the Done button doesn't trigger anything.  I click on it, and nothing happens.

    I followed your advice of checking the "Include Title Manager" when publishing via html.  It did stop an error that I was receiving (I was getting an error that said "You must run this content from a web-based server")...but my Done button doesn't work in either version.

    Help!
  • timk
    timk Community Member Posts: 1,147 ✶ Headliner ✶
    I've done some tests with a short test created with L16 on Windows 10 published to html

    Microsoft Edge - Done Button doesn't react neither online nor offline. The test is not processed. If I check "Show results" the Done Button will open an empty window but the OK button in the results window will again not do anything.

    Firefox - Works online and offline

    Chrome - Works online, but not offline

    At least they are all different, so I don't even have to try to understand...

    Interesting is that I know for sure that a randomized test created with Lectora 11 (Scorm 1.2 in moodle) works in Edge (online) without issues.

    Tim
Sign In or Register to comment.

So You Wanna Be An eLearning ROCKSTAR?

We're all fans of eLearning here! Want to become an eLearning ROCKSTAR? Just click on one of the buttons below to start your rocking journey!