Interaction Report Issue

alockwood6897
alockwood6897 Community Member Posts: 113 ♪ Opening Act ♪
I have attempted to find the answer elsewhere in the forums, but have not found anything regarding this issue.

In publishing out a course with a SCORM test in Lectora 12 to CourseMill, I have found that there are no issues with tracking students. However, when I try to run an Interaction report to examine question responses all of the data is there except the actual question text.

I must be missing something, but as far as I can tell, I have covered everything in the test properties, the test result properties, anywhere I can think that might have something to do with this, but I cannot get the question text to appear.

Has anyone else had this issue? Have you been able to fix it?

Comments

  • support
    support Community Member Posts: 96
    Hi Andy,

    Are you using the Publish to SCORM option or the Publish to CourseMill option? The question text isn't part of the SCORM standard. We only support it when you use the Publish to CourseMill option from Lectora.
  • ssneg
    ssneg Community Member Posts: 1,466 ☆ Roadie ☆
    @support, technically, there's the cmi.interactions.n.description[250] field that you could populate with the question text and then use it in the report.
  • alockwood6897
    alockwood6897 Community Member Posts: 113 ♪ Opening Act ♪
    @support: This is the exact piece of the puzzle I was looking for. There is a surprising lack of documentation out there for such things. I think I found one vague mention in the forums on how "question text no longer appears", but no explanation as to why in that thread.

    I have, up until this bit of troubleshooting, been uploading to CourseMill manually. Course creation in Lectora > Publish to SCORM > manual file upload inside CourseMill. The Publish to CourseMill not only fixed the question text issue, but it does save a bit of time on the upload process in general.

    Thanks for the response!

    @ssneg: Thank you for your input as well. I will have to look into this further. Is this function limited to SCORM 2004? We are running the SCORM 1.2 standard, so I am not sure that would be something I can use.
  • alockwood6897
    alockwood6897 Community Member Posts: 113 ♪ Opening Act ♪
    <span class="handle-sign">@&lt;/span>support: This is the exact piece of the puzzle I was looking for. There is a surprising lack of documentation out there for such things. I think I found one vague mention in the forums on how "question text no longer appears", but no explanation as to why in that thread.

    I have, up until this bit of troubleshooting, been uploading to CourseMill manually. Course creation in Lectora > Publish to SCORM > manual file upload inside CourseMill. The Publish to CourseMill not only fixed the question text issue, but it does save a bit of time on the upload process in general.

    Thanks for the response!
  • ssneg
    ssneg Community Member Posts: 1,466 ☆ Roadie ☆
  • support
    support Community Member Posts: 96
    Yep, the cmi.interactions.n.description[250] field Sergey mentions is only supported in SCORM 2004. CourseMill does not support SCORM 2004 at this time, only 1.2. So that's why the Publish to CourseMill option in Lectora is needed to get them added to the interactions.