Question coupling Rank/sequence question with an action group

mpost8193
mpost8193 Community Member Posts: 5
Can anybody help me with my following problem.

I am trying to couple a rank/sequence question to a loose action group. I want to use the if condition in the action group. If the question is correct I want to show a picture + feedback on the correct answer. If the question is not correct I want to show a different picture + feedback. And I do not want to use the feedback tab but model this myself. I tried to use in the if condition: If Question6 is correct. But this did not work. I also tried to use values which the program makes when the question is correct: If Question6 contains 1-1, 2-2, 3-3, 4-4, 5-5, 6-6 etc (number one is coupled to option one, which is correct etc). However, this did not work either.

Can anybody tell me how to solve this problem? What kind of values does Lectora use to check if the Rank question is correct (if all answers are placed in the right place).

Thank you!

Greetings Marijn

Comments

  • wendymiller
    wendymiller Community Member Posts: 244
    Hi Marijn,

    I am attaching a Lectora 11 library object (should also work in Lectora 12) that does what I think you are describing. If it doesn't, let me know and I'll try again.
  • mpost8193
    mpost8193 Community Member Posts: 5
    Hi Wendy,

    Thanx for your answer. Unfortunately, I cannot open the file with Lectora (it says the file is corrupt. I do have Lectora 11). Is it possible you upload it again?

    Furthermore, in the end I thought I solved my problem using an If construction. It works now in the preview of Lectora. However, when I publish it as an HTML it does not work anymore. Very frustrating! Is there a bug somewhere in these kind of questions?

    Thanx for your answer.

    Greetings Marijn

     

     

     

     
  • wendymiller
    wendymiller Community Member Posts: 244
    Hi Marijn,

    The attachment on my previous reply was a Lectora library object (.awo). To use a library object, you need to drag and drop it into the open Lectora application and it will expand in the Title Explorer automatically. In any case, I am attaching a Lectora .awt file this time. This one you can double click on to open.

    I am not aware of any issues with Rank and Sequence questions when publishing to HTML in Lectora v11. The one I am attaching works fine when I publish it to HTML. If you'd like to send me your question, I'd be happy to take a look at it. You can copy and paste the page that it is on into a new Lectora file, save it, zip up the folder, and attach it to your reply.

     
  • mpost8193
    mpost8193 Community Member Posts: 5
    Hi Wendy,

    I tried your Rank and Sequence and it indeed worked both in preview and HTML. The difference between your question and mine, is that I choose the option to "put the choices in a droplist". Strangely my question does work in HTML when I choose the standard rank option, however, when choosing the "put choices in droplist", functionality gets lost in HTML version (it still does work in preview). Maybe, the bug has something to do with the "put choices in the droplist"option?

    Although my question works now with the standard variant of the question, I think it looks better when I put the choices in a droplist. Do you have any idea how I can make it work?

    Thank you for all your answers!
  • wendymiller
    wendymiller Community Member Posts: 244
    Well I am baffled, Marijn. If I check the Show Choices In Droplist option for the rank and sequence question I attached earlier, it still works for me when I publish to HTML. There must be something else about your particular question that is causing it to not work. But I cannot guess what it would be. The value that the question variable gets is the same whether the choices are shown in a droplist or not. So I don't think it would be a text comparison issue.

    Perhaps your best option would be to submit a support ticket and send them your course. If there is indeed a bug, then they can help you work through it and also report the bug to the development team for fixing. On the right side of this page, under the Recently Active Members list, you will see a "Submit a support ticket" button.

    I'm sorry that I could not help more.