Submit button missing on only IE10

topdog
topdog Community Member Posts: 5
Hey Team



My first ever post!



I can normally find all the answer I need by reading over the forums but in this case I am stuck. I have created modules which are being saved and accessed on an internal sever. Once the users complete the module I get an email back with their answers. This has been working perfectly fine until some of my users upgraded from IE9 to IE10.



For the users using IE10 everything works perfectly fine until they get to the final page and need to complete the module by click submit. The button isn't there but for users on IE9 it is? That is the only thing that differs on the module between the two IE's. The only thing that makes that button different is it has the action, process test/survey.



I did find this thread and tried the fix it suggested because it sounded very close to my problem but it didn't work.



http://lectora.com/forum/showthread.php?t=14126



Any help is much appreciated as this is causing me major problems



Thanks team

Comments

  • topdog
    topdog Community Member Posts: 5
    I have tried to think of a way to solve my only problem and have come up with this idea. I need some help in the execution of it though.



    I was thinking of putting the submit test button on another page that the module never takes the user to. But on my final test page I would have a button that would look to the user as the submit button. This button would tell the button on the other page to do its thing. I am not sure if this is even possible to do, I cant find a way to make button interact with a button on another page?



    In simple terms - I want a button on page 1 when clicked, to make a button on page two act like its been clicked too?



    Any help is much appreciated
  • benpitman
    benpitman Community Member Posts: 763
    You did not say but there are a number of problems with Lectora X and later versions of IE, especially 10. I just found out that transitions to not work well and in fact cause other issues with a page. But when moved to 11, everything works fine. This is likely because Lectora X was developed BEFORE IE10 so there is no way they could have anticipated the problems. They seem to be fixed with Lectora 11. Which version of Lectora are you using?
  • topdog
    topdog Community Member Posts: 5
    Sorry I am using lectora 11.2a. I have done a heap of reading but cant find anyone having the exact problem.
  • topdog
    topdog Community Member Posts: 5
    Right I have got a bit further down the track with my problem. I now know its a Java problem. My users have limited access when it come to internet usage. So I upgrade one of my users Java and I have had some success. They now get a security message saying "an unsigned application from the location below is requesting permission to run"



    This is OK cause they can click "I accept" and then click run and then it works. This isn't the most professional look however so I have tried to find away to stop this message and just auto accept.



    I am told apparently I need a self signed certificate for Lectora as the severs we used are trusted. Can you get these, make them?



    Once again any help is appreciated
  • mongiovi
    mongiovi Community Member Posts: 5
    I had the same issue with IE10 and not being able to use the submit test action on the page itself, or on a button. Button never shows.



    I added an External HTML object, and chose "top of file scripting" with the following meta tag to make the page act as IE9:







    That fixed my problem.