Used embedded external font in lectora 11 not clear in IE8 & Mozilla Firefox

akash-jambhorkar
akash-jambhorkar Community Member Posts: 28
Hello all,



In my current e-learning course I used embedded external font in lectora 11 after publish text is not clear in IE8 & Mozilla Firefox browser. Can anyone have a solution?





Thanks & Regards

Akash

Comments

  • ssneg
    ssneg Community Member Posts: 1,466 ☆ Roadie ☆
    1. What do you mean by not clear? Show us a screenshot, please.

    2. Does the font look clear in IE8 and Firefox when used outside Lectora, in any other page? This might be the font problem.

    3. How are you embedding the font?
  • akash-jambhorkar
    akash-jambhorkar Community Member Posts: 28
    This is screen shot for unclear text on IE 8.



    [ATTACH=CONFIG]675[/ATTACH]
  • ssneg
    ssneg Community Member Posts: 1,466 ☆ Roadie ☆
    This does look unclear. Are you sure it isn't converted to image? How are you embedding it? Also, it doesn't look custom, more like standard Arial, are you sure it's even loaded?
  • ummakumma
    ummakumma Community Member Posts: 97
    @Akash Jambhorkar 64105 wrote:
    This is screen shot for unclear text on IE 8.



    [ATTACH=CONFIG]675[/ATTACH]


    I had a similar problem with IE8 when I had a fade or float transition on text.
  • akash-jambhorkar
    akash-jambhorkar Community Member Posts: 28
    Hi ssneg

    Thanks a ton for your reply.

    I would like to mention here I’m not converted text into image. Below steps I follow to embedding font in lectora please go through following steps:-

    Step 1:- Add external JS in extern folder.



    Step 2:-I added two HTML extensions in top of my project.



    [ATTACH=CONFIG]676[/ATTACH]



    Step 3:- In font link html extension file I go to in properties & in edit I write below script





    Step 4:- In External JS & In second HTML extension I added our JS code for that I refer below mention site & font also download from same site

    http://www.fontsquirrel.com/home



    Step 5:- After publish I added font folder on root (in html or scorm package publish folder).

    In font folder all required file type are added.



    And yes all fonts are loaded because its issue doesn’t come from my side; this issue comes from client side. I check Publish output all browsers but this is working for me .
  • ssneg
    ssneg Community Member Posts: 1,466 ☆ Roadie ☆
    Can you share the title?
  • ankitbnl406
    ankitbnl406 Community Member Posts: 7
    Hi,



    This is Ankit (eLearning Expert Developer).



    I will help in this, you have to check in the code level. Can you share the JS you have added with CSS files.



    regards,

    Ankit