LMSSetValue Error: Invalid Argument Type

spider
spider Community Member Posts: 4
I am fairly new to Lectora and I am currently working on several new courses for my work. When publishing the courses to the LMS we continue to receive the LMSSetValue Error stating invalid argument type. I am publishing via SCORM 2004 and I have added the AICC_Lesson_Status with the variables passed and failed. I have also added the CMI_Completion_Status with the variables completed and incomplete. All of the courses have tests at the end. The error shows up when exiting the course. The variables are on the page and haven't been added to the exit button. Any help would be greatly appreciated!

Comments

  • ssneg
    ssneg Community Member Posts: 1,456 ♪ Opening Act ♪
    AICC_Lesson_Status can only contain "completed" or "incomplete", exactly like this, nothing else, no caps, no spaces. If you try setting it to anything else, your LMS should respond with an error message. Similar principle applies to other SCORM variables.
  • spider
    spider Community Member Posts: 4
    @ssneg 59916 wrote:
    AICC_Lesson_Status can only contain "completed" or "incomplete", exactly like this, nothing else, no caps, no spaces. If you try setting it to anything else, your LMS should respond with an error message. Similar principle applies to other SCORM variables.


    I found similar information, but it said to use "passed" or "failed" for scorm 2004. I will try using "completed" and "incomplete" to see what happens. Anything at this point is appreciated. We are working around the problem by hiding the exit button and closing the browser.
  • ssneg
    ssneg Community Member Posts: 1,456 ♪ Opening Act ♪
    Here's full reference for all SCORM flavours - http://scorm.com/scorm-explained/technical-scorm/run-time/run-time-reference/





    Note:



    SCORM 1.2: cmi.core.lesson_status (“passed”, “completed”, “failed”, “incomplete”, “browsed”, “not attempted”, RW)

    SCORM 2004: cmi.completion_status (“completed”, “incomplete”, “not attempted”, “unknown”, RW)

    cmi.success_status (“passed”, “failed”, “unknown”, RW)
  • spider
    spider Community Member Posts: 4
    @Spider 59961 wrote:
    I found similar information, but it said to use "passed" or "failed" for scorm 2004. I will try using "completed" and "incomplete" to see what happens. Anything at this point is appreciated. We are working around the problem by hiding the exit button and closing the browser.


    Thanks for your help. I'm starting to think it is an issue with our LMS TOPYX. Everything is reporting correctly, but I still get the Invalid argument error when using the exit button. Closing the browser works without receiving the error.