Status Tracking condition not functioning properly Lectora 11when published SCORM

mgilbert
mgilbert Community Member Posts: 33 ☆ Roadie ☆
I am trying to creat a course completion percent function in my learning modules using the new Lectora 11 tracking status.



On each page I tried using an action to add "1" to a variable "pagecount" - using the condition "if this page" = "not started" so that the page only gets counted once.



Then I take that pagecount value and divide by "total pages"X100



Testing in Run Mode this works great and only counts the page once.



After published - the course completion percent never changes "0%"



If I take the condition off then it works fine - but you can add to "pagecount" variable by going back and each time you open a page it adds to it so will not function as a "course completion percent"



Seems like the condition "page not started" does not register correctly after published or in HTML.

Comments

  • lauram
    lauram Community Member Posts: 149
    I've tested out a basic sample title doing what you've described, and this works for me. I'm not aware of any bugs or issues with the status tracking in published titles. If you have a chance, will you send your title to support and send it to my attention (Laura Michalow)? I'd like to take a look and see if we can't figure out what's going on.



    Thanks!
  • mgilbert
    mgilbert Community Member Posts: 33 ☆ Roadie ☆
    See the Thread Below:



    Forum - Lectora - General Lectora Discussion - Progress Bar Lectora 11 TOC style wont keep progress



    The problem is still problematic but I can backcopy the course if you wish.



    Using:

    Scorm Cloud

    Publish Scorm 2004

    Browser Firefox 26.0



    Using these and I tried internet explorer - still did not work

    The conditons for "This Page" using Status "not started, in progress, complete" - do not work





    Also: Sometimes I would have to go to my TOC 3 times before it showed any status marks at all, just did not seem to be working. Even if I had viewed half the pages it still showed all status as "not started".



    In RUN mode it works PERFECT! In published mode it does not work.



    Let me know if I can be of further assistance
  • mgilbert
    mgilbert Community Member Posts: 33 ☆ Roadie ☆
    I went 4 pages into a 34 page course



    Status on TOC shows ALL pages completed.



    Scorm Cloud

    Scorm 2004 published

    Firefox Browser



    I tried uploading a picture but it gives me a 404 error code??
  • mgilbert
    mgilbert Community Member Posts: 33 ☆ Roadie ☆
    I went TOC back to the beginning of the course and completed 4 pages of 34 - Status now shows ALL pages NOT STARTED



    This is flaky, flaky.
  • mgilbert
    mgilbert Community Member Posts: 33 ☆ Roadie ☆
    THis is tracked with Browser Cookies - clear cookies and problem solved!!
  • rwalters
    rwalters Community Member Posts: 276
    Clearing cookies does not work for me. It's still showing all statuses as complete. I think it worked the first time I went through the title, but I would like to test it to make sure it works for a new user. Is there an action that can reset the status? No matter what I do, it shows everything as complete.



    Edit: This is published to HTML not SCORM.
  • mgilbert
    mgilbert Community Member Posts: 33 ☆ Roadie ☆
    Send to support ATT: Laura Michalow



    She helped me with this issue and has hinted at a bug fix for further problems with Status Tracking not reporting correctly in some situations.
  • rwalters
    rwalters Community Member Posts: 276
    I just sent an email to to support. They asked if my status indicators were in a group. They were, so removed them from the groups each was in.