Using themes to create content for different sized platforms - objects disappear

cotterpin
cotterpin Community Member Posts: 24 ♪ Opening Act ♪
Hiya,



I have been investigating how useful it would be to use themes to be able to create content for different sized platforms (desktop, iPad, smart phones). If I can get it to work I will maybe investigate creating my own custom themes.

I do have a couple of questions, however, before I proceed too far which I am hoping the splendid people on this forum will be able to help me with.



First of all, a general question. What are other people's experiences in using themes to create the same content for different platforms?



Secondly, a more specific question. I have noticed that when I create a Lectora title in one size and then save it as another size, some of the images and objects disappear!



The steps I am taking are as follows:

I create a new title and apply a theme to it.

I save the file

I resave the file as a separate Lectora title

In this version I apply a different size to the title (eg 320x416)

For the moment everything looks okay.

I save the file.

The header, footer and button images disappear!

I check in the images folder for the title and they have gone.

I apply a different theme - the objects appear on the screen and the images folder. When I click save they disappear again.



As anybody else experienced this? I am using Lectora 11.0



Thanks in advance for any help



Stephen

Comments

  • merceg
    merceg Community Member Posts: 107 ♪ Opening Act ♪
    Your items are probably still there, it is just that their locations are off the viewable page now since you resized it. Just click on them in the title explorer pane on the left-hand side of your title, click on their properties and then the position and size tab and make their coordinates 0,0 and you should see the object so that you can then drag it to where you need it to be on the resized page.
  • cotterpin
    cotterpin Community Member Posts: 24 ♪ Opening Act ♪
    Hi Melissa,

    Thanks for this. I have checked and the actual items have disappeared. The object is displayed in place on the screen and in the Title Explorer but the associated image is deleted from the images folder. When I close the Lectora title and re-open it I am prompted to browse for these images.

    It's a shame if this is an issue with Themes as it would be quite a useful way to create content for use on multiple platforms - if it worked!

    Best wishes

    Stephen
  • cotterpin
    cotterpin Community Member Posts: 24 ♪ Opening Act ♪
    Hiya,

    Just to let you all know that this issue appears to be resolved simply by upgrading to the latest version of Lectora. I am now running 11.3.2 and the problem does not appear to be occurring any more.

    I am however experiencing another problem relating to creating custom themes but I will start a new thread on that subject.

    Best wishes

    Stephen