Publish settings for SCORM greyed out

kselement
kselement Community Member Posts: 17
This is really frustrating me. Why are the publish settings greyed out so that you cant choose them!! How can I change these?[ATTACH=CONFIG]432[/ATTACH]

Comments

  • wheels
    wheels Florida USACommunity Member, Administrator, Moderator, Rockstar Manager Posts: 574 eLearning ROCKSTAR Admin Team
    The publish options are disabled because, for some reason, they are necessary or not applicable. I guess ideally it would tell you what things in the course cause this to happen, we will make note of that.



    There is some issue with the names of the pages in the title where it needs to generate the short page names. The most common reason is when there are pages with the same name. This generates a warning during the error check specifying there are multiple pages with the same name.



    Because it is generating the page names the convert accented characters in page names option is not applicable.



    Title Manager is necessary for any SCORM course, or when there is a random test, or other feature where we need to do state tracking.
  • kselement
    kselement Community Member Posts: 17
    @wheels 50687 wrote:
    The publish options are disabled because, for some reason, they are necessary or not applicable. I guess ideally it would tell you what things in the course cause this to happen, we will make note of that.



    There is some issue with the names of the pages in the title where it needs to generate the short page names. The most common reason is when there are pages with the same name. This generates a warning during the error check specifying there are multiple pages with the same name.



    Because it is generating the page names the convert accented characters in page names option is not applicable.



    Title Manager is necessary for any SCORM course, or when there is a random test, or other feature where we need to do state tracking.


    I wish this would help or answer my question, but it made things even more confusing considering I have made 2 SCORM courses from exactly the same template, and yet when I go to publish these 2 courses there are different checked/unchecked options that are greyed out. This caused a lot of problems with our LMS not being able to read the course. I then had to export the course, open in our VERY old version of Lectora, uncheck the option boxes, and the reimport the course back into Lectora Online.



    So we were not impressed with the amount of time we had to use to try and solve this problem. And from what you have said, I cant do anything about it?
  • wheels
    wheels Florida USACommunity Member, Administrator, Moderator, Rockstar Manager Posts: 574 eLearning ROCKSTAR Admin Team
    If the files are exactly the same then there is no reason the publish options should be different. This problem should be reported to [email protected]



    Again, look at the publishing messages, look for any warning messages (blue) that might give a clue to why those options are disabled. Typically it is because two pages have the same name.
  • kselement
    kselement Community Member Posts: 17
    The wonderful team at Trivantis found the problem and the solution. For anyone who might have similar problems with the publishing options being disabled, look at the course/title name in the highest folder of the tree structure, and make sure that you do not use any unusual characters.



    My problem was that I had used the wrong dash ( - ) in the title, which some browsers saw as a special character.
  • wheels
    wheels Florida USACommunity Member, Administrator, Moderator, Rockstar Manager Posts: 574 eLearning ROCKSTAR Admin Team
    We are adding a message that will let you know why the publishing options are being changed.



    In this case there was no message and even as a developer I was scratching my head! The dash was definitely not obvious, I think Mac OS or Microsoft Word use a different character code which results in a dash - that fails our valid filename character check. Thank you for reporting this to support and helping us make the product better.