Course will not mark as completed in LMS

pier
pier Community Member Posts: 22
Hi, here again to ask for some help. I don't know if this should be posted here or in the LMS section but here it is.



My Lectora title will not mark as completed in the LMS, it stays "in progress". I'm publishing to Cornerstone LMS in scorm 1.2 with an AICC_Lesson_Status set as completed and a separate exit button. What am I missing here?



Thanks all for your help,



Pier

Comments

  • susan_457
    susan_457 Community Member Posts: 1
    I am publishing to Cornerstone on Demand (SCORM 4), the first time I published I did not have the AICC Lesson Status set to equal completed and the course remained In Progress. The second time I uploaded it I had added the action AICC Lesson Status set to equal completed and I got the following error message LMSSetValue Error: Data Model Element type mismatch.



    Does anyone have any ideas?



    Thanks,

    Susan
  • wee
    wee Community Member Posts: 71
    Not sure if you try Complete or Completed. Sometime it is case sensitive.
  • kgun5
    kgun5 Community Member Posts: 8
    @Susan_457 62446 wrote:
    I am publishing to Cornerstone on Demand (SCORM 4), the first time I published I did not have the AICC Lesson Status set to equal completed and the course remained In Progress. The second time I uploaded it I had added the action AICC Lesson Status set to equal completed and I got the following error message LMSSetValue Error: Data Model Element type mismatch.



    Does anyone have any ideas?



    Thanks,

    Susan


    Susan,



    You may want to try setting some other values, as some LMSs need them for completion. As timk noted, setting AICC_Score is a good idea, but I have run into LMSs that require score.min, score.max, and score.raw to be set, as well.



    What I would try first, however, is setting the following three variables in your title:



    CMI_Completion_Status = completed

    CMI_Success_Status = passed

    AICC_Lesson_Status = passed
  • amwdmw
    amwdmw Community Member Posts: 97
    Try different versions of Completed/completed/Complete/complete - I used to use Cornerstone On Demand, and remember it was case-sensitive. But I don't remember what I used to have to put as the AICC value. In addition, make sure you have the "marked completed" action in the right spot. Does your exit button show up only when the course is done...and that's what triggers your "mark completed" action? If so, make your "mark completed" action appear when the button appears....not when the user clicks the button. I have had issues where the window closes before the trigger is applied - even if the actions were layered "correctly".



    Hope this helps...and good luck!
  • kfilut8375
    kfilut8375 Community Member Posts: 2
    I am having this issue, as well. I am using Lectora12, publishing to SCORM1.2. The AICC_Lesson_Status is set at complete, per the recommendation of all other Lcctora/LMS users in my company. There have been several of us trying to troubleshoot this. We have matched the variables and actions identically to several modules that are marking complete. I am at a loss.
  • shannon7305
    shannon7305 Community Member Posts: 12
    The value is normally: completed (all lower case, spelled with the d on the end)

    To set the lesson status, you need to place an action on the last page of your course (or the page that you want to tell the LMS that the course status has changed).

    Make sure that you place this action on a page that every user must view. First though, you need to make sure that you have your course configured properly.

    To configure, highlight the name of the course in the title explorer, go to Design tab, title options,  select the option for AICC/SCORM/CourseMill (3.x and above) Published Title.

    You now have access to the AICC variables. Set the action on the last page as follows

    On: Show
    Action: Modify Variable
    Target: AICC_Lesson_Status
    Value: (this value is set by your LMS and it varies, please consult your LMS)  usually this value is set as:  completed
    Leave everything else at defaults.

     
  • kfilut8375
    kfilut8375 Community Member Posts: 2
    This is exactly how it is configured in mine. *sigh* How frustrating.