PeopleSoft ELM/LMS

Chris Paxton
Chris Paxton Community Member Posts: 119 ☆ Superstar ☆
Hello-

This isn't really a question...but, I have been meaning to offer this assistance since they created the section LMS Integration (I was one of the many people that asked for the LMS's to be seperated from the General questions.)



Anyway...I have been using Lectora for a couple of years and we publish to PeopleSoft ELM (LMS) and have run into a lot of bugs; but have worked through most of them...and after my recent post to ASTD where I was asking for assistance, yet received sales offers and scolding as I was just wanting "free" advice I recalled that I never made this post....long story short.



Anyway, if you are needing assistance with Peoplesoft and Lectora please let me know. I am NOT an expert, but I do have some pretty good documentation that I am willing to share (for free - hehe! Well...I hope you would assist someone else when needed!)



Thanks!

Chris



Chrisanna Paxton McMillin, Specialist III Educational Technology

Cherokee Nation Entertainment
Chris Paxton McMillin, D3 Training Solutions
[email protected]
www.d3trainingsolutions.com

Comments

  • kristi_lozano
    kristi_lozano Community Member Posts: 11
    Hi Chris,



    I would greatly appreciate any documentation that you or anyone else have created to solve issues with Launching courses in ELM. So far, it's been a nightmare. The launch size is a small window, browser bars are showing, etc. We would like to side step the ELM API Launch settings and use full screen, etc.



    Please let me know if you are still having success and if you are launching courses in full screen. We are using ELM 9.1 and Lectora Inspire 11.3.2. Also, we are trying to launch UPK courses that require frames.



    Thanks so much!

    Kristi



    @cpaxton 35778 wrote:
    Hello-

    This isn't really a question...but, I have been meaning to offer this assistance since they created the section LMS Integration (I was one of the many people that asked for the LMS's to be seperated from the General questions.)



    Anyway...I have been using Lectora for a couple of years and we publish to PeopleSoft ELM (LMS) and have run into a lot of bugs; but have worked through most of them...and after my recent post to ASTD where I was asking for assistance, yet received sales offers and scolding as I was just wanting "free" advice I recalled that I never made this post....long story short.



    Anyway, if you are needing assistance with Peoplesoft and Lectora please let me know. I am NOT an expert, but I do have some pretty good documentation that I am willing to share (for free - hehe! Well...I hope you would assist someone else when needed!)



    Thanks!

    Chris



    Chrisanna Paxton McMillin, Specialist III Educational Technology

    Cherokee Nation Entertainment
  • john-sungail
    john-sungail Community Member Posts: 6
    Chris,

    I'm struggling through some issues with PeopleSoft LMS and would greatly appreciate any solutions! LMS will mark a test as 100% but display the course as "In Progress". I've added several VAR's to the last page but nothing seems to work.

     
  • lherkes7213
    lherkes7213 Community Member Posts: 4
    Hi Chrisanna, I'm fairly new to using Lectora v17, but have published a few basic modules.

    I have also managed to get them to integrate with Oracle LMS , with some help from our IT team.

    My query is whether you can both integrate with LMS and email results to our mailbox?

    If not, do you have a solution in terms of auditing results ? - we are using for Health and safety training and the auditors require to see the actual Q&A results.

    Hope you can help

    Linda
  • Chris Paxton
    Chris Paxton Community Member Posts: 119 ☆ Superstar ☆
    Hi Linda-

    Which Oracle LMS version are you using? We were able to email results using PeopleSoft 9.0 and 9.2, I will need to look up my notes to see how we did it, but I think (from memory) we just created a action to send via email the results...let me see if I can find my notes while I wait to hear what version you are using. :)
    Chris Paxton McMillin, D3 Training Solutions
    [email protected]
    www.d3trainingsolutions.com
  • lherkes7213
    lherkes7213 Community Member Posts: 4
    Hi Chrisanna, we are using Peoplesoft 9.2. We upgraded last year.

    many thanks

    Linda

     
  • mlenzke-1069
    mlenzke-1069 Community Member Posts: 8 ☆ Roadie ☆
    Hi Chris,

    We are experiencing occasional errors with Lectora courses in PeopleSoft ELM 9.2 when tests are being graded before the results are displayed. The error happens after LMSSetValue or in LMSIsInitialized and returns the error "TypeError: Cannot read properties of undefined". When the error occurs the rest of the page stops loading. The courses have been published in Lectora 18 and 19 for both SCORM 1.2 and 2004.

    Have you heard of or experienced this type of error before? Any help would be appreciated.

    Thanks,
    Marc
  • Chris Paxton
    Chris Paxton Community Member Posts: 119 ☆ Superstar ☆
    Hi Marc- I haven't, but it has been 5+ years since I've worked much in PeopleSoft. If I understand your question, correctly, you are saying the tests are being graded before the results are displayed...are you meaning before each individual question is graded? Otherwise the test will grade before it shows the "Test Results" page that is selected on the Test > Results contextual tab.

    So I can visualize it better, is this visible error that the students are seeing or on the reporting size?
    Could you strip your course and then zip it to let me look at it?

    Thanks!
    -Chris
    Chris Paxton McMillin, D3 Training Solutions
    [email protected]
    www.d3trainingsolutions.com
  • mlenzke-1069
    mlenzke-1069 Community Member Posts: 8 ☆ Roadie ☆
    Chris, thanks for the reply.

    When the learner selects their last answer in the test and selects the next button, the test is graded, the results are sent to ELM, but before the test results are shown on the Test Results screen there is an error that stops the results page from loading. We call this a "white screen" error because only a couple items on the screen load when the error happens and stops the rest of the code from processing. The learner doesn't see the actual error in a browser popup message or anything. I can see what the error is using the Google Chrome developer tools but it hasn't helped identify what is causing the error.

    This has been a tough one to troubleshoot because we can't replicate the error by following a set of steps. Some learners don't experience the error, some get it occasionally, and others seem to get it after completing every test.

    Marc
  • carlfink
    carlfink Community Member Posts: 1,102 ✭ Legend ✭
    Publish your course with debugging turned on, and see what point it reaches before it crashes.

    If you're familiar enough with the underlying technology, turn on the debugger in Chrome and see what happens right before the crash.
  • mlenzke-1069
    mlenzke-1069 Community Member Posts: 8 ☆ Roadie ☆
    I have used the Lectora debugger and had the Chrome dev tools open when testing the courses but it hasn't given any clues to what the cause of the error is. I've stepped through the code around the couple areas it seems to fail. I've also recently put code to write to the console to show when it starts and ends each function to give some more detail.

    I've included a screen shot of the console that shows one of the errors.


  • carlfink
    carlfink Community Member Posts: 1,102 ✭ Legend ✭
    edited January 25, 2022
    It seems to be trying to do something specific using the JavaScript SCORM API. I wonder if it's trying to access a particular field using SCORM that does not exist for certain people, say employee ID. Just a guess. I wonder that because of the "EMPLOYEE" in the parameter it's trying to set.

    EDIT: If that's the case, eLearning Brothers should really write some JS to trap the error seen here and give a useful error message to the user, in my opinion.
  • mlenzke-1069
    mlenzke-1069 Community Member Posts: 8 ☆ Roadie ☆
    Thanks for your thoughts. We've been fighting with this one for a while.